diff mbox series

[bug#42180,18/22] gnu: Add erlang-jsone.

Message ID a1527db49d9e2345a465e2061550737052859553.1593797694.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add extracting download, importer for hex.pm and rebar3 build-system for Erlang | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Hartmut Goebel July 3, 2020, 5:43 p.m. UTC
* gnu/packages/erlang.scm (erlang-jsone): New variable.
---
 gnu/packages/erlang.scm | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 69c4795195..cbe3fcadcd 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -431,6 +431,22 @@  arguments using the GNU getopt syntax.")
 specifications.")
     (license license:asl2.0)))
 
+(define-public erlang-jsone
+  (package
+    (name "erlang-jsone")
+    (version "1.5.2")
+    (source
+      (origin
+        (method hexpm-fetch)
+        (uri (hexpm-uri "jsone" version))
+        (sha256
+          (base32 "156dibk3hlvc04i7ss018mgx4bakcz7lagdnn0f2hj7lw8j63dhd"))))
+    (build-system rebar3-build-system)
+    (home-page "https://hexdocs.pm/jsone/")
+    (synopsis "Erlang JSON Library")
+    (description "Erlang JSON Library")
+    (license license:expat)))
+
 (define-public erlang-parse-trans
   (package
     (name "erlang-parse-trans")