diff mbox series

[bug#42180,22/22] gnu: Add erlang-rebar3-proper.

Message ID e2b5de2e7a40c6fac3065fa1d9578d28245482cf.1593797694.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add extracting download, importer for hex.pm and rebar3 build-system for Erlang | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Hartmut Goebel July 3, 2020, 5:43 p.m. UTC
* gnu/packages/erlang.scm (erlang-rebar3-proper): New variable.
---
 gnu/packages/erlang.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index e927f5db11..6f347ac37b 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -533,6 +533,23 @@  testing of stateful systems.")
 git.")
     (license license:expat)))
 
+(define-public erlang-rebar3-proper
+  (package
+    (name "erlang-rebar3-proper")
+    (version "0.11.1")
+    (source
+      (origin
+        (method hexpm-fetch)
+        (uri (hexpm-uri "rebar3_proper" version))
+        (sha256
+          (base32 "0gkbq69bvagh43w384fqgycpyr1p1zd3clwp1klcaicmp0x1syj9"))))
+    (build-system rebar3-build-system)
+    (home-page "http://proper.softlab.ntua.gr/")
+    (synopsis "Rebar3 PropEr plugin")
+    (description "This plugin allows running PropEr test suites from within
+rebar3.")
+    (license "BSD")))
+
 (define-public erlang-rebar3-raw-deps
   (package
     (name "erlang-rebar3-raw-deps")