diff mbox series

[bug#42180,17/22] gnu: Add erlang-edown.

Message ID 7baae3faa6cbe8f596e10e9e4c6add1b6b9e8a06.1593797694.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add extracting download, importer for hex.pm and rebar3 build-system for Erlang | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Hartmut Goebel July 3, 2020, 5:43 p.m. UTC
* gnu/packages/erlang.scm (erlang-edown): New variable.
---
 gnu/packages/erlang.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index f4ceb096a3..69c4795195 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -332,6 +332,23 @@  printing extending the io:format syntax to add colours.")
 outputs you want to be readable around all that noise they contain.")
     (license license:bsd-3)))
 
+(define-public erlang-edown
+  (package
+    (name "erlang-edown")
+    (version "0.8.1")
+    (source
+      (origin
+        (method hexpm-fetch)
+        (uri (hexpm-uri "edown" version))
+        (sha256
+          (base32 "1782j2nz0gdj839cag1bpimgd80hw034gj8az6lxpib543hk7vix"))))
+    (build-system rebar3-build-system)
+    (home-page "https://github.com/uwiger/edown")
+    (synopsis "Markdown extension for EDoc")
+    (description "This package provides an extension for EDoc for generating
+Markdown.")
+    (license "Apache 2.0")))
+
 (define-public erlang-erlware-commons
   (package
     (name "erlang-erlware-commons")