diff mbox series

[bug#42180,05/22] gnu: Add erlang-certifi.

Message ID 2b76108d4978a53d2aeef5047a7e2efc5ffa9842.1593797694.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add extracting download, importer for hex.pm and rebar3 build-system for Erlang | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Hartmut Goebel July 3, 2020, 5:43 p.m. UTC
* gnu/packages/erlang.scm (erlang-certifi): New variable.
---
 gnu/packages/erlang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index e8812f3cbd..e55cca7cc6 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -235,6 +235,30 @@  built-in support for concurrency, distribution and fault tolerance.")
 files.")
     (license license:asl2.0)))
 
+(define-public erlang-certifi
+  (package
+    (name "erlang-certifi")
+    (version "2.5.2")
+    (source
+     (origin
+       (method hexpm-fetch)
+       (uri (hexpm-uri "certifi" version))
+       (sha256
+        (base32 "1vb909y1jdhiwd8rc0pyx10dm889j952l05jb25rpa8aycbrvx3l"))))
+    (build-system rebar3-build-system)
+    (inputs
+     `(("parse-trans" ,erlang-parse-trans)))
+    (home-page "https://github.com/certifi/erlang-certifi/")
+    (synopsis "CA bundle adapted from Mozilla for Erlang")
+    (description "This Erlang library contains a CA bundle that you can
+reference in your Erlang application.  This is useful for systems that do not
+have CA bundles that Erlang can find itself, or where a uniform set of CAs is
+valuable.
+
+This an Erlang specific port of certifi.  The CA bundle is derived from
+Mozilla's canonical set.")
+    (license license:bsd-3))) ;; FIXME
+
 (define-public erlang-cf
   (package
     (name "erlang-cf")