diff mbox series

[bug#42180,13/22] gnu: Add erlang-hex-core.

Message ID c80389d19f1a349e405383828602a279760b74f9.1593797694.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add extracting download, importer for hex.pm and rebar3 build-system for Erlang | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Hartmut Goebel July 3, 2020, 5:43 p.m. UTC
* gnu/packages/erlang.scm (erlang-hex-core): New variable.
---
 gnu/packages/erlang.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index bdd3fbaf34..b3fc6f0abb 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -386,6 +386,34 @@  of reusable Erlang components.")
 arguments using the GNU getopt syntax.")
     (license license:bsd-3)))
 
+(define-public erlang-hex-core
+  (package
+    (name "erlang-hex-core")
+    (version "0.6.9")
+    (source
+     (origin
+       (method hexpm-fetch)
+       (uri (hexpm-uri "hex_core" version))
+       (sha256
+        (base32 "13drqw7pdqbmir4wbn0lgrclzhdhm758pb71ra8ysq5zhfrjzdv4"))))
+    (build-system rebar3-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (invoke "rebar3" "as" "test" "proper"))))))
+    (inputs
+     `(("erlang-proper" ,erlang-proper)
+       ("erlang-rebar3-proper" ,erlang-rebar3-proper)))
+    (propagated-inputs
+     `(("erlang-getopt" ,erlang-getopt)))
+    (home-page "https://github.com/hexpm/hex_core")
+    (synopsis "Reference implementation of Hex specifications")
+    (description "This package provides the reference implementation of Hex
+specifications.")
+    (license license:asl2.0)))
+
 (define-public erlang-parse-trans
   (package
     (name "erlang-parse-trans")