diff mbox series

[bug#70735,097/714] gnu: python-aiosqlite: Remove python-coverage native-input.

Message ID 20240503224254.28001-97-ngraves@ngraves.fr
State New
Headers show
Series [bug#70735,001/714] gnu: python-transient: Remove python-black native-input. | expand

Commit Message

Nicolas Graves May 3, 2024, 10:19 p.m. UTC
* gnu/packages/databases.scm (python-aiosqlite):
  [arguments]<#:phases>: Adapt check phase.
  [native-inputs]: Remove python-coverage.

Change-Id: I165d174426022f0603223e3def91ffe280f15899
---
 gnu/packages/databases.scm | 14 ++++++--------
 1 file changed, 6 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 1ac5d35056..955eed7cef 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3936,15 +3936,13 @@  (define-public python-aiosqlite
                 "1a8sggh1wwbpl46k5qcfmp97s9hjysna0x7mwwc53kyfm0m95wf8"))))
     (build-system pyproject-build-system)
     (arguments
-     (list #:phases #~(modify-phases %standard-phases
-                        (replace 'check
-                          (lambda* (#:key tests? #:allow-other-keys)
-                            (when tests?
-                              (invoke "python" "-m" "coverage" "run" "-m"
-                                      "aiosqlite.tests")
-                              (invoke "python" "-m" "coverage" "report")))))))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     (invoke "python" "-m" "aiosqlite.tests")))))))
     (native-inputs (list python-flit-core
-                         python-coverage
                          python-mypy))
     (home-page "https://github.com/jreese/aiosqlite")
     (synopsis