diff mbox series

[bug#70735,036/714] gnu: python-codespell: Remove python-flake8 native-input.

Message ID 20240503224254.28001-36-ngraves@ngraves.fr
State New
Headers show
Series [bug#70735,001/714] gnu: python-transient: Remove python-black native-input. | expand

Commit Message

Nicolas Graves May 3, 2024, 10:18 p.m. UTC
* gnu/packages/python-xyz.scm (python-codespell):
  [arguments]: Remove uneeded field.
  [native-inputs]: Remove python-flake8.

Change-Id: I1ca51f5320527300a556e64c59c6c2c9d5230f23
---
 gnu/packages/python-xyz.scm | 14 +-------------
 1 file changed, 1 insertion(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7f2d56ac15..4519b8468f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19589,25 +19589,13 @@  (define-public python-codespell
     (inputs
       (list python-chardet))
     (native-inputs
-      (list python-flake8
-            python-pygments
+      (list python-pygments
             python-pytest
             python-pytest-cov
             python-pytest-dependency
             python-tomli
             python-setuptools
             python-wheel))
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key outputs tests? #:allow-other-keys)
-             (when tests?
-               ;; Make installed executable available for running the tests.
-               (setenv "PATH"
-                       (string-append (assoc-ref outputs "out") "/bin"
-                                      ":" (getenv "PATH")))
-               (invoke "pytest" "-vv")))))))
     (home-page "https://github.com/codespell-project/codespell/")
     (synopsis "Spellchecker for code")
     (description "Codespell fixes common misspellings in text files.