diff mbox series

[bug#70735,093/714] gnu: u-boot-tools: Remove python-coverage native-input.

Message ID 20240503224254.28001-93-ngraves@ngraves.fr
State New
Headers show
Series [bug#70735,001/714] gnu: python-transient: Remove python-black native-input. | expand

Commit Message

Nicolas Graves May 3, 2024, 10:19 p.m. UTC
* gnu/packages/bootloaders.scm (u-boot-tools):
  [native-inputs]: Remove python-coverage.
  [arguments]<#:phases>: Adapt patch phase.

Change-Id: I94394544079197b4a3f8c53cc0b3d78d1f5dc8be
---
 gnu/packages/bootloaders.scm | 17 ++++-------------
 1 file changed, 4 insertions(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 0e7bc66bd7..cf568b2bd6 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -802,8 +802,7 @@  (define-public u-boot-tools
     (name "u-boot-tools")
     (native-inputs
      (modify-inputs (package-native-inputs u-boot)
-       (prepend python-coverage
-                python-filelock
+       (prepend python-filelock
                 python-pycryptodomex
                 python-pytest
                 python-pytest-xdist
@@ -820,14 +819,6 @@  (define-public u-boot-tools
                (("/bin/false") (which "false")))
              (substitute* "tools/dtoc/fdt_util.py"
                (("'cc'") "'gcc'"))
-             (substitute* "tools/u_boot_pylib/test_util.py"
-               ;; python3-coverage is simply called coverage in guix.
-               (("python3-coverage") "coverage")
-
-               ;; Don't require 100% coverage since it's brittle and can
-               ;; fail with newer versions of coverage or dependencies.
-               (("raise ValueError\\('Test coverage failure'\\)")
-                "print('Continuing anyway since Guix does not care :O')"))
              (substitute* "test/run"
                ;; Make it easier to find test failures.
                (("#!/bin/bash") "#!/bin/bash -x")
@@ -838,9 +829,9 @@  (define-public u-boot-tools
                ;; FIXME: test_spl fails, needs further investiation
                (("test_ofplatdata or test_handoff or test_spl")
                 "test_ofplatdata or test_handoff")
-               ;; FIXME: code coverage not working
-               (("run_test \"binman code coverage\"")
-                "# run_test \"binman code coverage\"")
+               ;; Disable code coverage tests.
+               (("run_test \"(\\w+) code coverage\"" all)
+                (string-append "# " all))
                ;; This test would require internet access.
                (("\\./tools/buildman/buildman") (which "true")))
              (substitute* "test/py/tests/test_sandbox_exit.py"