diff mbox series

[bug#64209,05/14] gnu: Add ocaml-stdune.

Message ID fc802394583c538bf0a007f8082e70ce0194474d.1687361650.git.benjamin@uvy.fr
State New
Headers show
Series Add ocaml-lsp-server and its dependencies | expand

Commit Message

Benjamin June 21, 2023, 3:48 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-stdune): New variable.
---
 gnu/packages/ocaml.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 5ad86c7c20..3e5fe7c92a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -9735,6 +9735,27 @@  (define-public ocaml-dyn
     (synopsis "Dynamic type")
     (description "Dynamic type")))
 
+(define-public ocaml-stdune
+  (package
+    (inherit dune)
+    (name "ocaml-stdune")
+    (build-system dune-build-system)
+    (arguments
+     '(#:package "stdune"
+       #:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (add-before 'build 'remove-vendor
+                    (lambda _
+                      (delete-file-recursively "vendor/csexp")
+                      (delete-file-recursively "vendor/pp"))))))
+    (propagated-inputs (list ocaml-dyn ocaml-ordering ocaml-pp ocaml-csexp
+                             ocaml-odoc))
+    (properties '())
+    (synopsis "Dune's unstable standard library")
+    (description
+     "This library offers no backwards compatibility guarantees.  Use at your own
+risk.")))
+
 (define-public ocaml-either
   (package
     (name "ocaml-either")