diff mbox series

[bug#64209,08/14] gnu: Add ocaml-ordering.

Message ID 03f780c110ad01c8e7ebbb42c2252d110e191b8d.1687361650.git.benjamin@uvy.fr
State New
Headers show
Series Add ocaml-lsp-server and its dependencies | expand

Commit Message

Benjamin June 21, 2023, 3:48 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-ordering): New variable.
---
 gnu/packages/ocaml.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index da3794ad33..0d856aad8a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -9795,6 +9795,24 @@  (define-public ocaml-xdg
     (description
      "https://specifications.freedesktop.org/basedir-spec/basedir-spec-latest.html")))
 
+(define-public ocaml-ordering
+  (package
+    (inherit dune)
+    (name "ocaml-ordering")
+    (build-system dune-build-system)
+    (arguments
+     '(#:package "ordering"
+       #:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (add-before 'build 'remove-vendor
+                    (lambda _
+                      (delete-file-recursively "vendor/csexp")
+                      (delete-file-recursively "vendor/pp"))))))
+    (propagated-inputs (list ocaml-odoc))
+    (properties '())
+    (synopsis "Element ordering")
+    (description "Element ordering")))
+
 (define-public ocaml-either
   (package
     (name "ocaml-either")