diff mbox series

[bug#64209,09/14] gnu: Add ocamlc-loc.

Message ID 216839fea045d048ef99cec4e808a8f166be689e.1687361650.git.benjamin@uvy.fr
State New
Headers show
Series Add ocaml-lsp-server and its dependencies | expand

Commit Message

Benjamin June 21, 2023, 3:48 p.m. UTC
* gnu/packages/ocaml.scm (ocamlc-loc): New variable.
---
 gnu/packages/ocaml.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 0d856aad8a..e482541d60 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -9813,6 +9813,26 @@  (define-public ocaml-ordering
     (synopsis "Element ordering")
     (description "Element ordering")))
 
+(define-public ocamlc-loc
+  (package
+    (inherit dune)
+    (name "ocamlc-loc")
+    (build-system dune-build-system)
+    (arguments
+     '(#:package "ocamlc-loc"
+       #:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (add-before 'build 'remove-vendor
+                    (lambda _
+                      (delete-file-recursively "vendor/csexp")
+                      (delete-file-recursively "vendor/pp"))))))
+    (propagated-inputs (list ocaml-dyn ocaml-odoc))
+    (properties '())
+    (synopsis "Parse ocaml compiler output into structured form")
+    (description
+     "This library offers no backwards compatibility guarantees.  Use at your own
+risk.")))
+
 (define-public ocaml-either
   (package
     (name "ocaml-either")