diff mbox series

[bug#64209,10/14] gnu: Add ocamlformat-rpc-lib.

Message ID f1090ae7e004abab1c141c7eade57de1e05d77ec.1687361650.git.benjamin@uvy.fr
State New
Headers show
Series Add ocaml-lsp-server and its dependencies | expand

Commit Message

Benjamin June 21, 2023, 3:48 p.m. UTC
* gnu/packages/ocaml.scm (ocamlformat-rpc-lib): New variable.
---
 gnu/packages/ocaml.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index e482541d60..30eb7e2209 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -9908,6 +9908,20 @@  (define-public ocamlformat
 a uniform style.")
     (license license:expat)))
 
+(define-public ocamlformat-rpc-lib
+  (package
+    (inherit ocamlformat)
+    (name "ocamlformat-rpc-lib")
+    (arguments
+     '(#:package "ocamlformat-rpc-lib"
+       #:tests? #f))
+    (propagated-inputs (list ocaml-csexp ocaml-odoc))
+    (synopsis "Auto-formatter for OCaml code (RPC mode)")
+    (description
+     "OCamlFormat is a tool to automatically format OCaml code in a uniform style.
+This package defines a RPC interface to OCamlFormat")))
+
+
 (define-public ocaml-bigstringaf
   (package
     (name "ocaml-bigstringaf")