diff mbox series

[bug#64209,07/14] gnu: Add ocaml-xdg.

Message ID d8de5f4cf07a707e8716d204d2beaf04296a0531.1687361650.git.benjamin@uvy.fr
State New
Headers show
Series Add ocaml-lsp-server and its dependencies | expand

Commit Message

Benjamin June 21, 2023, 3:48 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-xdg): New variable.
---
 gnu/packages/ocaml.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 730a6ee014..da3794ad33 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -9776,6 +9776,25 @@  (define-public ocaml-fiber
      "This library offers no backwards compatibility guarantees.  Use at your own
 risk.")))
 
+(define-public ocaml-xdg
+  (package
+    (inherit dune)
+    (name "ocaml-xdg")
+    (build-system dune-build-system)
+    (arguments
+     '(#:package "xdg"
+       #:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (add-before 'build 'remove-vendor
+                    (lambda _
+                      (delete-file-recursively "vendor/csexp")
+                      (delete-file-recursively "vendor/pp"))))))
+    (propagated-inputs (list ocaml-odoc))
+    (properties '())
+    (synopsis "XDG Base Directory Specification")
+    (description
+     "https://specifications.freedesktop.org/basedir-spec/basedir-spec-latest.html")))
+
 (define-public ocaml-either
   (package
     (name "ocaml-either")