diff mbox series

[bug#64209,04/14] gnu: Add ocaml-dyn.

Message ID fc1837c4bce7788c178c452d2210dc5a8b907f8b.1687361650.git.benjamin@uvy.fr
State New
Headers show
Series Add ocaml-lsp-server and its dependencies | expand

Commit Message

Benjamin June 21, 2023, 3:48 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-dyn): New variable.
---
 gnu/packages/ocaml.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 078c7837e7..5ad86c7c20 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -9717,6 +9717,24 @@  (define-public ocaml-chrome-trace
 risk.")
     (license license:expat)))
 
+(define-public ocaml-dyn
+  (package
+    (inherit dune)
+    (name "ocaml-dyn")
+    (build-system dune-build-system)
+    (arguments
+     '(#:package "dyn"
+       #:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (add-before 'build 'remove-vendor
+                    (lambda _
+                      (delete-file-recursively "vendor/csexp")
+                      (delete-file-recursively "vendor/pp"))))))
+    (propagated-inputs (list ocaml-ordering ocaml-pp ocaml-odoc))
+    (properties '())
+    (synopsis "Dynamic type")
+    (description "Dynamic type")))
+
 (define-public ocaml-either
   (package
     (name "ocaml-either")