diff mbox series

[bug#64209,14/14] gnu: Add ocaml-lsp-server.

Message ID 083d46189e6881fbcaf5b1d391164a5d74a9bf4f.1687361650.git.benjamin@uvy.fr
State New
Headers show
Series Add ocaml-lsp-server and its dependencies | expand

Commit Message

Benjamin June 21, 2023, 3:48 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-lsp-server): New variable.
---
 gnu/packages/ocaml.scm | 43 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 726f47a0e4..5306c7881a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6331,6 +6331,49 @@  (define-public ocaml5.0-merlin
 Atom.")
      (license license:expat))))
 
+;this package is not public because 1.16.1 only support ocaml 5.0 and 5.1
+(define ocaml-lsp-server
+  (package
+    (name "ocaml-lsp-server")
+    (version "1.16.1")
+    (home-page "https://github.com/ocaml/ocaml-lsp")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                (url home-page)
+                (commit version)))
+              (sha256
+               (base32
+                "09410g0mmwhgcrxyygdzabmx26ahsa5madcs38ah2b6jygic4dzb"))))
+    (build-system dune-build-system)
+    (arguments '(#:tests? #f)) ; tests are failing for v1.16.1
+    (propagated-inputs (list ocaml-merlin-lib-4.9
+                             ocamlformat-rpc-lib
+                             ocaml-pp
+                             ocamlc-loc
+                             ocaml-spawn
+                             ocaml-ordering
+                             ocaml-fiber
+                             ocaml-dyn
+                             ocaml-dune-rpc
+                             ocaml-re
+                             ocaml-csexp
+                             ocaml-uutf
+                             ocaml-odoc-parser
+                             ocaml-dune-build-info
+                             ocaml-xdg
+                             ocaml-stdune
+                             ocaml-chrome-trace
+                             ocaml-ppx-yojson-conv-lib
+                             ocaml-yojson))
+    (native-inputs (list ocaml-ppx-expect ocamlformat ocaml-odoc))
+    (properties `((upstream-name . "ocaml-lsp-server")))
+    (synopsis "LSP Server for OCaml")
+    (description "An LSP server for OCaml.")
+    (license license:isc)))
+
+(define-public ocaml5.0-lsp-server (package-with-ocaml5.0 ocaml-lsp-server))
+
 (define-public ocaml-gsl
   (package
     (name "ocaml-gsl")