diff mbox series

[bug#64209,02/14] gnu: Add ocaml-dune-rpc.

Message ID 3f8769082b56273ea3b212014e09b4ce1fd84115.1687361650.git.benjamin@uvy.fr
State New
Headers show
Series Add ocaml-lsp-server and its dependencies | expand

Commit Message

Benjamin June 21, 2023, 3:48 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-dune-rpc): New variable.
---
 gnu/packages/ocaml.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 7aa87ca4df..18825f607a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -9672,6 +9672,30 @@  (define-public ocaml-dune-build-info
 reporting the version from the version control system during development to
 get an precise reference of when the executable was built.")))
 
+(define-public ocaml-dune-rpc
+  (package
+    (inherit dune)
+    (name "ocaml-dune-rpc")
+    (build-system dune-build-system)
+    (arguments
+     '(#:package "dune-rpc"
+       #:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (add-before 'build 'remove-vendor
+                    (lambda _
+                      (delete-file-recursively "vendor/csexp")
+                      (delete-file-recursively "vendor/pp"))))))
+    (propagated-inputs (list ocaml-csexp
+                             ocaml-ordering
+                             ocaml-dyn
+                             ocaml-xdg
+                             ocaml-stdune
+                             ocaml-pp
+                             ocaml-odoc))
+    (properties '())
+    (synopsis "Communicate with dune using rpc")
+    (description "Library to connect and control a running dune instance")))
+
 (define-public ocaml-either
   (package
     (name "ocaml-either")