diff mbox series

[bug#64209,06/14] gnu: Add ocaml-fiber.

Message ID 33226aafe04e813c4141e5a3487ab31b863c78fe.1687361650.git.benjamin@uvy.fr
State New
Headers show
Series Add ocaml-lsp-server and its dependencies | expand

Commit Message

Benjamin June 21, 2023, 3:48 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-fiber): New variable.
---
 gnu/packages/ocaml.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 3e5fe7c92a..730a6ee014 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -9756,6 +9756,26 @@  (define-public ocaml-stdune
      "This library offers no backwards compatibility guarantees.  Use at your own
 risk.")))
 
+(define-public ocaml-fiber
+  (package
+    (inherit dune)
+    (name "ocaml-fiber")
+    (build-system dune-build-system)
+    (arguments
+     '(#:package "fiber"
+       #:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (add-before 'build 'remove-vendor
+                    (lambda _
+                      (delete-file-recursively "vendor/csexp")
+                      (delete-file-recursively "vendor/pp"))))))
+    (propagated-inputs (list ocaml-stdune ocaml-dyn ocaml-odoc))
+    (properties '())
+    (synopsis "Structured concurrency library")
+    (description
+     "This library offers no backwards compatibility guarantees.  Use at your own
+risk.")))
+
 (define-public ocaml-either
   (package
     (name "ocaml-either")