diff mbox series

[bug#67921,v2,11/23] gnu: Add ghc-heaps-bootstrap-for-9.6

Message ID f76b21175d5c22c9926c7a325a6a76afbc1ed3e6.1707827100.git.saku@laesvuori.fi
State New
Headers show
Series Update GHC to 9.6.4 | expand

Commit Message

Saku Laesvuori Feb. 15, 2024, 8:49 a.m. UTC
* gnu/packages/haskell.scm (ghc-heaps-bootstrap-for-9.6): New variable.

Change-Id: Ib04a47d3eacba415fd44cd532c18c02f8d9cf40b
---
 gnu/packages/haskell.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 3561e494d2..a83d785554 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1655,6 +1655,27 @@  (define ghc-random-bootstrap-for-9.6
 library, including the ability to split random number generators.")
     (license license:bsd-3)))
 
+(define ghc-heaps-bootstrap-for-9.6
+  (package
+    (name "ghc-heaps-bootstrap")
+    (version "0.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "heaps" version))
+       (sha256
+        (base32 "1zbw0qrlnhb42v04phzwmizbpwg21wnpl7p4fbr9xsasp7w9scl9"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "heaps")))
+    (arguments (list #:haskell ghc-bootstrap-for-9.6))
+    (home-page "http://github.com/ekmett/heaps/")
+    (synopsis "Asymptotically optimal Brodal/Okasaki heaps.")
+    (description
+     "Asymptotically optimal Brodal\\/Okasaki bootstrapped skew-binomial heaps from the
+paper <http://citeseerx.ist.psu.edu/viewdoc/summary?doi=10.1.1.48.973 \"Optimal
+Purely Functional Priority Queues\">, extended with a Foldable interface.")
+    (license license:bsd-3)))
+
 (define ghc-utf8-string-bootstrap-for-9.6
   (package
     (name "ghc-utf8-string-bootstrap")