diff mbox series

[bug#67921,v2,18/23] gnu: Add ghc-unordered-containers-bootstrap-for-9.6

Message ID 4f3d4f1d26348b10303c4b1f2590007db93300f7.1707827100.git.saku@laesvuori.fi
State New
Headers show
Series Update GHC to 9.6.4 | expand

Commit Message

Saku Laesvuori Feb. 15, 2024, 8:49 a.m. UTC
* gnu/packages/haskell.scm (ghc-unordered-containers-bootstrap-for-9.6):
  New variable.

Change-Id: I190d7e765d30b469290d26109478fbe97dfbe3ae
---
 gnu/packages/haskell.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index d163331b2b..3b591c6ffa 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1533,6 +1533,33 @@  (define ghc-js-flot-bootstrap-for-9.6
 requirements of downstream users (e.g. Debian).")
     (license license:expat)))
 
+(define ghc-unordered-containers-bootstrap-for-9.6
+  (package
+    (name "ghc-unordered-containers-bootstrap")
+    (version "0.2.19.1")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "unordered-containers" version))
+              (sha256
+               (base32
+                "1li8s6qw8mgv6a7011y7hg0cn2nllv2g9sr9c1xb48nmw32vw9qv"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "unordered-containers")))
+    (inputs (list ghc-hashable-bootstrap-for-9.6))
+    (arguments
+     `(#:cabal-revision ("3"
+                         "1p9a2mvfbfz2d4cyr16b03bxvb6c4yj7k1ch601xwq1rkr1cla0w")
+       #:haskell ,ghc-bootstrap-for-9.6
+       #:tests? #f))
+    (home-page
+     "https://github.com/haskell-unordered-containers/unordered-containers")
+    (synopsis "Efficient hashing-based container types")
+    (description
+     "Efficient hashing-based container types.  The containers have been
+optimized for performance critical use, both in terms of large data quantities
+and high speed.")
+    (license license:bsd-3)))
+
 (define ghc-cryptohash-sha256-bootstrap-for-9.6
   (package
     (name "ghc-cryptohash-sha256-bootstrap")