diff mbox series

[bug#67921,v2,12/23] gnu: Add ghc-js-dgtable-bootstrap-for-9.6

Message ID cbb9dc256cba13f7b98092f7ac012364bc1185b8.1707827100.git.saku@laesvuori.fi
State New
Headers show
Series Update GHC to 9.6.4 | expand

Commit Message

Saku Laesvuori Feb. 15, 2024, 8:49 a.m. UTC
* gnu/packages/haskell.scm (ghc-js-dgtable-bootstrap-for-9.6): New
  variable.

Change-Id: Ic7e9e6c584e4fb8830ec55288759796271822964
---
 gnu/packages/haskell.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index a83d785554..88c7278168 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1655,6 +1655,29 @@  (define ghc-random-bootstrap-for-9.6
 library, including the ability to split random number generators.")
     (license license:bsd-3)))
 
+(define ghc-js-dgtable-bootstrap-for-9.6
+  (package
+    (name "ghc-js-dgtable-bootstrap")
+    (version "0.5.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "js-dgtable" version))
+       (sha256
+        (base32 "1b10kx703kbkb5q1ggdpqcrxqjb33kh24khk21rb30w0xrdxd3g2"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "js-dgtable")))
+    (arguments (list #:haskell ghc-bootstrap-for-9.6))
+    (home-page "https://github.com/ndmitchell/js-dgtable#readme")
+    (synopsis "Obtain minified jquery.dgtable code")
+    (description
+     "This package bundles the minified <https://github.com/danielgindi/jquery.dgtable
+jquery.dgtable> code into a Haskell package, so it can be depended upon by Cabal
+packages.  The first three components of the version number match the upstream
+jquery.dgtable version.  The package is designed to meet the redistribution
+requirements of downstream users (e.g. Debian).")
+    (license license:expat)))
+
 (define ghc-heaps-bootstrap-for-9.6
   (package
     (name "ghc-heaps-bootstrap")