diff mbox series

[bug#67921,v2,04/23] gnu: Add ghc-extra-bootstrap-for-9.6

Message ID 7e65460e888f1493803b733a1f7bad7857751d4c.1707827100.git.saku@laesvuori.fi
State New
Headers show
Series Update GHC to 9.6.4 | expand

Commit Message

Saku Laesvuori Feb. 15, 2024, 8:49 a.m. UTC
* gnu/packages/haskell.scm (ghc-extra-bootstrap-for-9.6): New
  variable.

Change-Id: I73f1bd1a821bb01fc9d081c78313e583ce8fab6b
---
 gnu/packages/haskell.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index c2f0d8a160..717181b424 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1533,6 +1533,30 @@  (define ghc-js-flot-bootstrap-for-9.6
 requirements of downstream users (e.g. Debian).")
     (license license:expat)))
 
+(define ghc-extra-bootstrap-for-9.6
+  (package
+    (name "ghc-extra-bootstrap")
+    (version "1.7.12")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "extra" version))
+              (sha256
+               (base32
+                "0g5h8fp0nq4k9asiknw0bhvb10zpfnsixfp0n3xz0rc83pnajwg5"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "extra")))
+    (arguments (list #:tests? #f
+                     #:haskell ghc-bootstrap-for-9.6))
+    (inputs (list ghc-clock-bootstrap-for-9.6))
+    (home-page "https://github.com/ndmitchell/extra#readme")
+    (synopsis "Extra Haskell functions")
+    (description
+     "This library provides extra functions for the standard
+Haskell libraries.  Most functions are simple additions, filling out missing
+functionality.  A few functions are available in later versions of GHC, but
+this package makes them available back to GHC 7.2.")
+    (license license:bsd-3)))
+
 (define ghc-clock-bootstrap-for-9.6
   (package
     (name "ghc-clock-bootstrap")