diff mbox series

[bug#67921,v2,23/23] gnu: ghc: Update to version 9.6.4

Message ID 64d0be34c74b765c544e16a1f9115a774357f183.1707827100.git.saku@laesvuori.fi
State New
Headers show
Series Update GHC to 9.6.4 | expand

Commit Message

Saku Laesvuori Feb. 15, 2024, 8:50 a.m. UTC
* gnu/packages/haskell.scm (ghc): Update to ghc-9.6

Change-Id: I40da6cacc4d260902cd66d7d626375038fba4346
---
 gnu/packages/haskell.scm | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index e316fc860e..3944d8f15f 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1393,12 +1393,6 @@  (define-public ghc-9.2
               (file-pattern ".*\\.conf\\.d$")
               (file-type 'directory)))))))
 
-;; Versions newer than ghc defined below (i.e. the compiler
-;; haskell-build-system uses) should use ghc-next as their name to
-;; ensure ghc (without version specification) and ghc-* packages are
-;; always compatible. See https://issues.guix.gnu.org/issue/47335.
-(define-public ghc ghc-9.2)
-
 ;; 9.4 is the last version to support the make-based build system,
 ;; but it boot with 9.2, only 9.0 is supported.
 (define ghc-bootstrap-for-9.4 ghc-9.0)
@@ -1462,7 +1456,7 @@  (define-public ghc-9.4
   (let ((base ghc-9.2))
     (package
       (inherit base)
-      (name "ghc-next")
+      (name "ghc")
       (version "9.4.8")
       (source (origin
                 (method url-fetch)
@@ -2061,7 +2055,7 @@  (define-public ghc-9.6
   (let ((base ghc-9.4))
     (package
       (inherit base)
-      (name "ghc-next")
+      (name "ghc")
       (version "9.6.4")
       (source (origin
                 (inherit (package-source base))
@@ -2162,4 +2156,10 @@  (define-public ghc-9.6
               (file-pattern ".*\\.conf\\.d$")
               (file-type 'directory)))))))
 
+;; Versions newer than ghc defined below (i.e. the compiler
+;; haskell-build-system uses) should use ghc-next as their name to
+;; ensure ghc (without version specification) and ghc-* packages are
+;; always compatible. See https://issues.guix.gnu.org/issue/47335.
+(define-public ghc ghc-9.6)
+
 ;;; haskell.scm ends here