diff mbox series

[bug#67921,v2,17/23] gnu: Add ghc-cryptohash-sha256-bootstrap-for-9.6

Message ID 5024925e614ba9b15470aabd183169ce60c4e273.1707827100.git.saku@laesvuori.fi
State New
Headers show
Series Update GHC to 9.6.4 | expand

Commit Message

Saku Laesvuori Feb. 15, 2024, 8:49 a.m. UTC
* gnu/packages/haskell.scm (ghc-cryptohash-sha256-bootstrap-for-9.6):
  New variable.

Change-Id: I80dd73de554160f4dc904c01ea292a886f51e970
---
 gnu/packages/haskell.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 348a67f1c5..d163331b2b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1533,6 +1533,35 @@  (define ghc-js-flot-bootstrap-for-9.6
 requirements of downstream users (e.g. Debian).")
     (license license:expat)))
 
+(define ghc-cryptohash-sha256-bootstrap-for-9.6
+  (package
+    (name "ghc-cryptohash-sha256-bootstrap")
+    (version "0.11.102.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "cryptohash-sha256" version))
+       (sha256
+        (base32
+         "1xkb7iqplbw4fy1122p79xf1zcb7k44rl0wmfj1q06l7cdqxr9vk"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "cryptohash-sha256")))
+    (arguments
+     `(#:cabal-revision
+       ("1" "1hyzqv30rpj920ddnr0zypyjjlh52vyp2d140pn2byayj820rkgs")
+       #:haskell ,ghc-bootstrap-for-9.6
+       #:tests? #f))
+    (home-page "https://github.com/hvr/cryptohash-sha1")
+    (synopsis "SHA-256 implementation for Haskell")
+    (description "This Haskell package provides an incremental and
+one-pass, pure API to the @uref{https://en.wikipedia.org/wiki/SHA-2,
+SHA-256 cryptographic hash algorithm}, with performance close to the
+fastest implementations available in other languages.
+
+The implementation is made in C with a haskell FFI wrapper that hides
+the C implementation.")
+    (license license:bsd-3)))
+
 (define ghc-base16-bytestring-bootstrap-for-9.6
   (package
     (name "ghc-base16-bytestring-bootstrap")