diff mbox series

[bug#67921,v2,14/23] gnu: Add ghc-tagged-bootstrap-for-9.6

Message ID 754e2c787ada867156e382f4b167de1f03710456.1707827100.git.saku@laesvuori.fi
State New
Headers show
Series Update GHC to 9.6.4 | expand

Commit Message

Saku Laesvuori Feb. 15, 2024, 8:49 a.m. UTC
* gnu/packages/haskell.scm (ghc-tagged-bootstrap-for-9.6): New variable.

Change-Id: Ifd3996a62cfa33d155315807d4ead706f7e64452
---
 gnu/packages/haskell.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 604b38cce6..0f49aabdb1 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1655,6 +1655,26 @@  (define ghc-random-bootstrap-for-9.6
 library, including the ability to split random number generators.")
     (license license:bsd-3)))
 
+(define ghc-tagged-bootstrap-for-9.6
+  (package
+    (name "ghc-tagged-bootstrap")
+    (version "0.8.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "tagged" version))
+       (sha256
+        (base32
+         "0qdr1kv1zn5iamnwyn5nf0ywxs4wv779k0gpw94kyqx14ynfw534"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "tagged")))
+    (arguments (list #:haskell ghc-bootstrap-for-9.6))
+    (home-page "https://hackage.haskell.org/package/tagged")
+    (synopsis "Haskell phantom types to avoid passing dummy arguments")
+    (description "This library provides phantom types for Haskell 98, to avoid
+having to unsafely pass dummy arguments.")
+    (license license:bsd-3)))
+
 (define ghc-nats-bootstrap-for-9.6
   (package
     (name "ghc-nats-bootstrap")