diff mbox series

[bug#67921,v2,10/23] gnu: Add ghc-utf8-string-bootstrap-for-9.6

Message ID b6dce692d4ff5f41170ab8ac28c63b85f7a21faa.1707827100.git.saku@laesvuori.fi
State New
Headers show
Series Update GHC to 9.6.4 | expand

Commit Message

Saku Laesvuori Feb. 15, 2024, 8:49 a.m. UTC
* gnu/packages/haskell.scm (ghc-utf8-string-bootstrap-for-9.6): New
  variable.

Change-Id: Iea2ba4d3202195a54b71037882352cdac9415901
---
 gnu/packages/haskell.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 9f442e25a1..3561e494d2 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1655,6 +1655,28 @@  (define ghc-random-bootstrap-for-9.6
 library, including the ability to split random number generators.")
     (license license:bsd-3)))
 
+(define ghc-utf8-string-bootstrap-for-9.6
+  (package
+    (name "ghc-utf8-string-bootstrap")
+    (version "1.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "utf8-string" version))
+       (sha256
+        (base32 "16mh36ffva9rh6k37bi1046pgpj14h0cnmj1iir700v0lynxwj7f"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "utf8-string")))
+    (arguments `(#:tests? #f
+                 #:haskell ,ghc-bootstrap-for-9.6))
+    (home-page "https://github.com/glguy/utf8-string/")
+    (synopsis "Support for reading and writing UTF8 Strings")
+    (description
+     "A UTF8 layer for Strings.  The utf8-string package provides operations
+for encoding UTF8 strings to Word8 lists and back, and for reading and writing
+UTF8 without truncation.")
+    (license license:bsd-3)))
+
 (define ghc-js-jquery-bootstrap-for-9.6
   (package
     (name "ghc-js-jquery-bootstrap")