diff mbox series

[bug#67921,v2,15/23] gnu: Add ghc-semigroups-bootstrap-for-9.6

Message ID b445a688642189d47fbbd64098af401aab9ddcb6.1707827100.git.saku@laesvuori.fi
State New
Headers show
Series Update GHC to 9.6.4 | expand

Commit Message

Saku Laesvuori Feb. 15, 2024, 8:49 a.m. UTC
* gnu/packages/haskell.scm (ghc-semigroups-bootstrap-for-9.6): New
  variable.

Change-Id: Ic676fed80bea3805f8e70cd958c3d7523226053d
---
 gnu/packages/haskell.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 0f49aabdb1..6a19287d4a 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1655,6 +1655,36 @@  (define ghc-random-bootstrap-for-9.6
 library, including the ability to split random number generators.")
     (license license:bsd-3)))
 
+(define ghc-semigroups-bootstrap-for-9.6
+  (package
+    (name "ghc-semigroups-bootstrap")
+    (version "0.20")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "semigroups" version))
+              (sha256
+               (base32
+                "1qbk6scp1rzb69dy8mz26p6az5vi16g2lzwmwnfshh3br4rjwbch"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "semigroups")))
+    (arguments (list #:haskell ghc-bootstrap-for-9.6))
+    (inputs
+     (list ghc-nats-bootstrap-for-9.6
+           ghc-tagged-bootstrap-for-9.6
+           ghc-unordered-containers-bootstrap-for-9.6
+           ghc-hashable-bootstrap-for-9.6))
+    (home-page "http://github.com/ekmett/semigroups/")
+    (synopsis "Semigroup operations for Haskell")
+    (description
+     "This package provides semigroups for Haskell.  In
+mathematics, a semigroup is an algebraic structure consisting of a set
+together with an associative binary operation.  A semigroup generalizes a
+monoid in that there might not exist an identity element.  It
+also (originally) generalized a group (a monoid with all inverses) to a type
+where every element did not have to have an inverse, thus the name
+semigroup.")
+    (license license:bsd-3)))
+
 (define ghc-tagged-bootstrap-for-9.6
   (package
     (name "ghc-tagged-bootstrap")