diff mbox series

[bug#64209,v3,03/14] gnu: Add ocamlformat-rpc-lib.

Message ID ebe642583948659af8d78a451bd3591b091487ab.1699630991.git.benjamin@uvy.fr
State New
Headers show
Series improve synopsies and descriptions | expand

Commit Message

Benjamin Nov. 10, 2023, 3:46 p.m. UTC
* gnu/packages/ocaml.scm (ocamlformat-rpc-lib): New variable.

Change-Id: I960fb7bb4647c1ec1def870d5ec5afe6411347cf
---
 gnu/packages/ocaml.scm | 13 +++++++++++++
 1 file changed, 13 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 497588c4ea..3aeec614ca 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -9743,6 +9743,19 @@  (define-public ocamlformat
 a uniform style.")
     (license license:expat)))
 
+(define-public ocamlformat-rpc-lib
+  (package
+    (inherit ocamlformat)
+    (name "ocamlformat-rpc-lib")
+    (arguments
+     '(#:package "ocamlformat-rpc-lib"
+       #:tests? #f))
+    (propagated-inputs (list ocaml-csexp ocaml-odoc))
+    (synopsis "Auto-formatter for OCaml code in RPC mode")
+    (description
+     "OCamlFormat is a tool to automatically format OCaml code in a uniform style.
+This package defines a RPC interface to OCamlFormat.")))
+
 (define-public ocaml-bigstringaf
   (package
     (name "ocaml-bigstringaf")