diff mbox series

[bug#64209,v3,02/14] gnu: Add ocaml-pp.

Message ID e33a01b5729a4b7fa02ff08cbcc816595bd8f7d3.1699630991.git.benjamin@uvy.fr
State New
Headers show
Series improve synopsies and descriptions | expand

Commit Message

Benjamin Nov. 10, 2023, 3:46 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-pp): New variable.

Change-Id: Ic1782f531515802facb7fbcaea35405feffe2dc3
---
 gnu/packages/ocaml.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 2fd2f8e9f9..497588c4ea 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1980,6 +1980,33 @@  (define-public ocaml5.0-csexp
     (propagated-inputs
      `(("ocaml-result" ,ocaml5.0-result)))))
 
+(define-public ocaml-pp
+  (package
+    (name "ocaml-pp")
+    (version "1.1.2")
+    (home-page "https://github.com/ocaml-dune/pp")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url home-page)
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0w7gxa85ffbd6jgs6ziarq69yi423f0qkpk05r3abh6lg8smw8pg"))))
+    (build-system dune-build-system)
+    (native-inputs (list ocaml-ppx-expect))
+    (synopsis "Pretty-printing library for ocaml that aims to be easy to use")
+    (description
+     "This library provides a lean alternative to the Format module of the OCaml
+standard library.  It aims to make it easy for users to do the right thing.  If
+you have tried Format before but find its API complicated and difficult to use,
+then Pp might be a good choice for you.  Pp uses the same concepts of boxes and
+break hints, and the final rendering is done to formatter from the Format
+module.  However it defines its own algebra which some might find easier to work
+with and reason about.")
+    (license license:expat)))
+
 (define-public ocaml-migrate-parsetree
   (package
     (name "ocaml-migrate-parsetree")