diff mbox series

[bug#64209,v3,12/14] gnu: Add ocaml-dune-rpc.

Message ID 0d1362ebc5b2475bcc6a2a0cd9a6b07ff90b28e1.1699630991.git.benjamin@uvy.fr
State New
Headers show
Series improve synopsies and descriptions | expand

Commit Message

Benjamin Nov. 10, 2023, 3:46 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-dune-rpc): New variable.

Change-Id: Iccdb76ffa3ca7a896de9f349939df77dfaca35f8
---
 gnu/packages/ocaml.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 733bcd011e..e96beeed56 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -9691,6 +9691,30 @@  (define-public ocaml-dune-build-info
 reporting the version from the version control system during development to
 get an precise reference of when the executable was built.")))
 
+(define-public ocaml-dune-rpc
+  (package
+    (inherit dune)
+    (name "ocaml-dune-rpc")
+    (build-system dune-build-system)
+    (arguments
+     '(#:package "dune-rpc"
+       #:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (add-before 'build 'remove-vendor
+                    (lambda _
+                      (delete-file-recursively "vendor/csexp")
+                      (delete-file-recursively "vendor/pp"))))))
+    (propagated-inputs (list ocaml-csexp
+                             ocaml-ordering
+                             ocaml-dyn
+                             ocaml-xdg
+                             ocaml-stdune
+                             ocaml-pp
+                             ocaml-odoc))
+    (properties '())
+    (synopsis "Communicate with ocaml dune using rpc")
+    (description "Library to connect and control a running dune instance.")))
+
 (define-public ocaml-chrome-trace
   (package
     (inherit dune)