diff mbox series

[bug#64209,v3,06/14] gnu: Add ocaml-dyn.

Message ID b282750919e32cec71b90fc1d809e9571f0df4ab.1699630991.git.benjamin@uvy.fr
State New
Headers show
Series improve synopsies and descriptions | expand

Commit Message

Benjamin Nov. 10, 2023, 3:46 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-dyn): New variable.

Change-Id: I4f35a5e3e9271f70cfd88845964d24257d1d0ddf
---
 gnu/packages/ocaml.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 1b4bd8685e..0cafb8c6ee 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -9691,6 +9691,25 @@  (define-public ocaml-dune-build-info
 reporting the version from the version control system during development to
 get an precise reference of when the executable was built.")))
 
+(define-public ocaml-dyn
+  (package
+    (inherit dune)
+    (name "ocaml-dyn")
+    (build-system dune-build-system)
+    (arguments
+     '(#:package "dyn"
+       #:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (add-before 'build 'remove-vendor
+                    (lambda _
+                      (delete-file-recursively "vendor/csexp")
+                      (delete-file-recursively "vendor/pp"))))))
+    (propagated-inputs (list ocaml-ordering ocaml-pp ocaml-odoc))
+    (properties '())
+    (synopsis "Ocaml dynamic type library")
+    (description "Representation of OCaml values such that they can be
+processed without knowing their type.")))
+
 (define-public ocaml-ordering
   (package
     (inherit dune)