diff mbox series

[bug#64209,v3,07/14] gnu: Add ocaml-stdune.

Message ID a36d15f35c19c41069de88a006d868af16464d04.1699630991.git.benjamin@uvy.fr
State New
Headers show
Series improve synopsies and descriptions | expand

Commit Message

Benjamin Nov. 10, 2023, 3:46 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-stdune): New variable.

Change-Id: Iac602da6a41ed99264c9a20fac989d43e2e9ed0d
---
 gnu/packages/ocaml.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 0cafb8c6ee..a97ae57b56 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -9710,6 +9710,27 @@  (define-public ocaml-dyn
     (description "Representation of OCaml values such that they can be
 processed without knowing their type.")))
 
+(define-public ocaml-stdune
+  (package
+    (inherit dune)
+    (name "ocaml-stdune")
+    (build-system dune-build-system)
+    (arguments
+     '(#:package "stdune"
+       #:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (add-before 'build 'remove-vendor
+                    (lambda _
+                      (delete-file-recursively "vendor/csexp")
+                      (delete-file-recursively "vendor/pp"))))))
+    (propagated-inputs (list ocaml-dyn ocaml-ordering ocaml-pp ocaml-csexp
+                             ocaml-odoc))
+    (properties '())
+    (synopsis "Ocaml Dune's unstable standard library")
+    (description
+     "This library is dune standard library. It offers no backwards
+compatibility guarantees.")))
+
 (define-public ocaml-ordering
   (package
     (inherit dune)