diff mbox series

[bug#64209,v3,04/14] gnu: Add ocaml-ppx-yojson-conv-lib.

Message ID 347a36477eb86e13a2a6158641c75b4de6e29486.1699630991.git.benjamin@uvy.fr
State New
Headers show
Series improve synopsies and descriptions | expand

Commit Message

Benjamin Nov. 10, 2023, 3:46 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-ppx-yojson-conv-lib): New variable.

Change-Id: Iff772e4492ec80071ba99ba473164da9440a1f63
---
 gnu/packages/ocaml.scm | 25 ++++++++++++++++++++++++-
 1 file changed, 24 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 3aeec614ca..6cf88e08c0 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6135,7 +6135,30 @@  (define-public ocaml-yojson
 yojson package.  The program @code{atdgen} can be used to derive OCaml-JSON
 serializers and deserializers from type definitions.")
     (license license:bsd-3)))
- 
+
+(define-public ocaml-ppx-yojson-conv-lib
+  (package
+    (name "ocaml-ppx-yojson-conv-lib")
+    (version "0.15.0")
+    (home-page "https://github.com/janestreet/ppx_yojson_conv_lib")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+          (url home-page)
+          (commit (string-append "v" version))))
+        (sha256
+         (base32
+          "0slc5cwy60vx8gskmn20hmndjncpp5zs80a9wm7hxv8yl003i60y"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list ocaml-yojson))
+    (properties `((upstream-name . "ppx_yojson_conv_lib")))
+    (synopsis "Runtime library used by ocaml PPX yojson convertor")
+    (description "Ppx_yojson_conv_lib is the runtime library used by
+ppx_yojson_conv, a ppx rewriter that can be used to convert ocaml types
+to a Yojson.Safe value.")
+    (license license:expat)))
+
 (define-public ocaml-merlin-lib
   (package
     (name "ocaml-merlin-lib")