diff mbox series

[bug#64209,v3,09/14] gnu: Add ocaml-xdg.

Message ID a7e05e3db1194290adf0f33674cbac6aadd9fd89.1699630991.git.benjamin@uvy.fr
State New
Headers show
Series improve synopsies and descriptions | expand

Commit Message

Benjamin Nov. 10, 2023, 3:46 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-xdg): New variable.

Change-Id: Ie4246d9e655fafd60e650ac8043bdc6d51bcb737
---
 gnu/packages/ocaml.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 76cc995753..a12e7f4264 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -9753,6 +9753,26 @@  (define-public ocaml-stdune
      "This library is dune standard library. It offers no backwards
 compatibility guarantees.")))
 
+(define-public ocaml-xdg
+  (package
+    (inherit dune)
+    (name "ocaml-xdg")
+    (build-system dune-build-system)
+    (arguments
+     '(#:package "xdg"
+       #:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (add-before 'build 'remove-vendor
+                    (lambda _
+                      (delete-file-recursively "vendor/csexp")
+                      (delete-file-recursively "vendor/pp"))))))
+    (propagated-inputs (list ocaml-odoc))
+    (properties '())
+    (synopsis "XDG Base Directory Specification library for ocaml")
+    (description
+     "This ocaml library returns user XDG directories such as XDG_CONFIG_HOME,
+     XDG_STATE_HOME.")))
+
 (define-public ocaml-ordering
   (package
     (inherit dune)