diff mbox series

[bug#64209,v3,08/14] gnu: Add ocaml-chrome-trace.

Message ID a64bdfd9d04ff5b2ffb7d151630216b13ab7e7be.1699630991.git.benjamin@uvy.fr
State New
Headers show
Series improve synopsies and descriptions | expand

Commit Message

Benjamin Nov. 10, 2023, 3:46 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-chrome-trace): New variable.

Change-Id: I3c761ff694a0be32171df0fa3f57c6930b9c5438
---
 gnu/packages/ocaml.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a97ae57b56..76cc995753 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -9691,6 +9691,28 @@  (define-public ocaml-dune-build-info
 reporting the version from the version control system during development to
 get an precise reference of when the executable was built.")))
 
+(define-public ocaml-chrome-trace
+  (package
+    (inherit dune)
+    (name "ocaml-chrome-trace")
+    (build-system dune-build-system)
+    (arguments
+     '(#:package "chrome-trace"
+       #:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (add-before 'build 'remove-vendor
+                    (lambda _
+                      (delete-file-recursively "vendor/csexp")
+                      (delete-file-recursively "vendor/pp"))))))
+    (propagated-inputs (list ocaml-odoc))
+    (properties '())
+    (synopsis "Chrome trace event generation library for ocaml")
+    (description
+     "Output trace data to a file in Chrome's trace_event format. This format is
+    compatible with chrome trace viewer chrome://tracing.
+    This library offers no backwards compatibility guarantees.")
+    (license license:expat)))
+
 (define-public ocaml-dyn
   (package
     (inherit dune)