diff mbox series

[bug#64209,v3,10/14] gnu: Add ocamlc-loc.

Message ID a79c69b50ac1706a9e9437747e5786c9c10547be.1699630991.git.benjamin@uvy.fr
State New
Headers show
Series improve synopsies and descriptions | expand

Commit Message

Benjamin Nov. 10, 2023, 3:46 p.m. UTC
* gnu/packages/ocaml.scm (ocamlc-loc): New variable.

Change-Id: I6f07101aa27eb5879ab8c33a72e4278ba09b6b92
---
 gnu/packages/ocaml.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a12e7f4264..2af4f4133f 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -9792,6 +9792,26 @@  (define-public ocaml-ordering
     (description "This library implement element ordering and a convenient
 operator for efficiently chaining multiple comparisons together.")))
 
+(define-public ocamlc-loc
+  (package
+    (inherit dune)
+    (name "ocamlc-loc")
+    (build-system dune-build-system)
+    (arguments
+     '(#:package "ocamlc-loc"
+       #:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (add-before 'build 'remove-vendor
+                    (lambda _
+                      (delete-file-recursively "vendor/csexp")
+                      (delete-file-recursively "vendor/pp"))))))
+    (propagated-inputs (list ocaml-dyn ocaml-odoc))
+    (properties '())
+    (synopsis "Parse ocaml compiler output into structured form")
+    (description
+     "This library parses ocaml complier output and returns it as ocaml values.
+This library offers no backwards compatibility guarantees.")))
+
 (define-public ocaml-either
   (package
     (name "ocaml-either")