diff mbox series

[bug#70858,07/32] gnu: python-cram: Remove python-coverage native-input.

Message ID 20240510075605.6303-7-ngraves@ngraves.fr
State New
Headers show
Series None | expand

Commit Message

Nicolas Graves May 10, 2024, 7:55 a.m. UTC
* gnu/packages/python-xyz.scm (python-cram):
  [native-inputs]: Remove python-coverage.
  [build-system]: Move to pyproject-build-system.
  [arguments]<#:phases>: Adapt check and patch-source phases
  to coverage removal.

Change-Id: I83fafcdcfbc977f9d3e3411d01d23d9a0e120ec6
---
 gnu/packages/python-xyz.scm | 16 ++++------------
 1 file changed, 4 insertions(+), 12 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e84ce7df3eb..108b32d0459 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15081,25 +15081,17 @@  (define-public python-cram
                ;; causes the line showing the default shell to break into two
                ;; lines, but the test expects a single line...
                (("env\\['COLUMNS'\\] = '80'")
-                "env['COLUMNS'] = '160'"))
-
-             (substitute* "Makefile"
-               ;; Recent versions of python-coverage have caused the test
-               ;; coverage to decrease (as of version 0.7).  Allow that.
-               (("--fail-under=100")
-                "--fail-under=90"))
-
-             #t))
+                "env['COLUMNS'] = '160'"))))
          (replace 'check
            ;; The test phase uses the built library and executable.
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (add-installed-pythonpath inputs outputs)
              (setenv "PATH" (string-append (getenv "PATH") ":"
                                            (assoc-ref outputs "out") "/bin"))
-             (invoke "make" "test"))))))
-    (build-system python-build-system)
+             (invoke "make" "quicktest"))))))
+    (build-system pyproject-build-system)
     (native-inputs
-     (list python-coverage python-setuptools python-wheel which))
+     (list python-setuptools python-wheel which))
     (synopsis "Simple testing framework for command line applications")
     (description
      "Cram is a functional testing framework for command line applications.