diff mbox series

[bug#70858,05/32] build-system/pyproject: Remove python-flake8 inputs.

Message ID 20240510075605.6303-5-ngraves@ngraves.fr
State New
Headers show
Series None | expand

Commit Message

Nicolas Graves May 10, 2024, 7:55 a.m. UTC
* gnu/packages/astronomy.scm (python-crds)[native-inputs]: Remove
python-flake8.

* gnu/packages/bioinformatics.scm (python-doubletdetection,
python-biom-format)[native-inputs]: Remove python-flake8.

* gnu/packages/ebook.scm (calibre)[native-inputs]: Remove
python-flake8.

* gnu/packages/engineering.scm (python-scikit-rf)[native-inputs]:
Remove python-flake8.

* gnu/packages/finance.scm (python-mt-940)[native-inputs]: Remove
python-flake8.

* gnu/packages/geo.scm (python-geopy)[native-inputs]: Remove
python-flake8.

* gnu/packages/gettext.scm (python-mdpo)[native-inputs]: Remove
python-flake8.

* gnu/packages/graph.scm (python-pygsp)[native-inputs]: Remove
python-flake8.

* gnu/packages/graphviz.scm (python-uqbar)[native-inputs]: Remove
python-flake8.

* gnu/packages/machine-learning.scm (python-funsor,
python-imbalanced-learn, python-captum, python-pyro-api,
python-pyro-ppl, python-linear-operator,
python-gpytorch)[native-inputs]: Remove python-flake8.

* gnu/packages/music.scm (python-mutagen):
  [arguments]<#:test-flags>: Ignore flake8 quality tests.
  [native-inputs]: Remove python-flake8.

* gnu/packages/protobuf.scm (python-pure-protobuf):
  [arguments]<#:phases>: Remove flake8 invocation from check phase.
  [native-inputs]: Remove python-flake8.

* gnu/packages/python-web.scm (python-ovh, python-furl,
python-httplib2, python-http-ece, python-woob,
python-starsessions-for-pytorch-lightning)[native-inputs]: Remove
python-flake8.

* gnu/packages/python-xyz.scm (python-apispec,
python-apispec-webframeworks, python-apprise, python-colorful,
python-pymd4c, python-pyls-black, python-docx, python-flasgger,
python-imageio, python-importlib-ressources, python-jaraco-test,
python-seaborn, python-progressbar2, python-inflect,
python-argcomplete, python-diff-cover, python-validators,
python-marshmallow, python-marshmallow-jsonapi, python-yq,
python-update-checker, python-eliot, python-dateparser,
python-jinja2-cli, python-nikola, python-verspec, python-mike,
python-arpeggio, python-versioneer, python-codespell)[native-inputs]:
Remove python-flake8.

* gnu/packages/simulation.scm (python-dolfin-adjoint)[native-inputs]:
Remove python-flake8.

* gnu/packages/sphinx.scm (python-sphinx,
python-sphinx-5)[propagated-inputs]: Remove python-flake8.

* gnu/packages/statistics.scm (python-statsmodels)[native-inputs]:
Remove python-flake8.

* gnu/packages/vpn.scm (sshuttle)[native-inputs]: Remove
python-flake8.

* gnu/packages/wm.scm (qtile)[native-inputs]: Remove python-flake8.

* gnu/packages/textutils.scm (python-panflute)[native-inputs]: Remove
python-flake8.

Change-Id: I196a9c0b7497106c8f98598535cb8e0ea667481c
---
 gnu/packages/astronomy.scm        |  3 +-
 gnu/packages/bioinformatics.scm   |  7 +---
 gnu/packages/ebook.scm            |  1 -
 gnu/packages/engineering.scm      |  1 -
 gnu/packages/finance.scm          |  4 +-
 gnu/packages/geo.scm              |  1 -
 gnu/packages/gettext.scm          |  1 -
 gnu/packages/graph.scm            |  3 +-
 gnu/packages/graphviz.scm         |  1 -
 gnu/packages/machine-learning.scm | 15 ++------
 gnu/packages/music.scm            |  5 ++-
 gnu/packages/protobuf.scm         |  4 +-
 gnu/packages/python-web.scm       | 12 ++----
 gnu/packages/python-xyz.scm       | 62 +++++++++++--------------------
 gnu/packages/simulation.scm       |  1 -
 gnu/packages/sphinx.scm           |  2 -
 gnu/packages/statistics.scm       |  1 -
 gnu/packages/textutils.scm        |  1 -
 gnu/packages/vpn.scm              |  1 -
 gnu/packages/wm.scm               |  1 -
 20 files changed, 37 insertions(+), 90 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 32c6f30e8f6..ede10ab927a 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2186,8 +2186,7 @@  (define-public python-crds
                              python-roman-datamodels
                              python-stsynphot
                              python-requests))
-    (native-inputs (list python-flake8
-                         python-ipython
+    (native-inputs (list python-ipython
                          python-lockfile
                          python-mock
                          python-nose
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 253c36947c3..4f3a3d0ba01 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2152,8 +2152,7 @@  (define-public python-doubletdetection
            python-scipy
            python-tqdm))
     (native-inputs
-     (list python-flake8
-           python-poetry-core
+     (list python-poetry-core
            python-pytest))
     (home-page "https://github.com/JonathanShor/DoubletDetection")
     (synopsis
@@ -3005,7 +3004,6 @@  (define-public python-biom-format
     (propagated-inputs
      (list python-anndata
            python-click
-           python-flake8
            python-future
            python-h5py
            python-numpy
@@ -21833,8 +21831,7 @@  (define-public scvelo
            python-umap-learn
            pybind11))
     (native-inputs
-     (list python-flake8
-           python-hypothesis
+     (list python-hypothesis
            python-pytest
            python-setuptools-scm
            python-wheel))
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 16d4fcd6e36..3d536e59add 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -154,7 +154,6 @@  (define-public calibre
     (native-inputs
      (list bash-minimal
            pkg-config
-           python-flake8
            python-pyqt-builder
            qtbase-5                     ; for qmake
            xdg-utils))
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index f082f346278..610fb53087b 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2679,7 +2679,6 @@  (define-public python-scikit-rf
                              python-qtpy
                              python-scipy))
     (native-inputs (list python-coverage
-                         python-flake8
                          python-nbval
                          python-networkx
                          python-pytest
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 7d1efde8187..7579001dd1f 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -2307,9 +2307,7 @@  (define-public python-mt-940
                         ;; Remove custom --cov flags.
                         (delete-file "pytest.ini")
                         (invoke "pytest" "-vv")))))))
-    (native-inputs (list python-flake8
-                         python-pytest
-                         python-pyyaml))
+    (native-inputs (list python-pytest python-pyyaml))
     (home-page "https://mt940.readthedocs.io/")
     (synopsis "Python parser for MT940-encoded SWIFT data")
     (description
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 81a854f8a2a..69cc7e6ddc5 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -3265,7 +3265,6 @@  (define-public python-geopy
     (native-inputs
      (list python-async-generator
            python-coverage
-           python-flake8
            python-isort
            python-pytest
            python-pytest-aiohttp
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 1408cc4cb46..bbb19bd4cb8 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -214,7 +214,6 @@  (define-public mdpo
     (build-system python-build-system)
     (native-inputs
      (list python-bump2version
-           python-flake8
            python-flake8-implicit-str-concat
            python-flake8-print
            python-isort
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 033027a5aa9..eb8aa17fdfe 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -564,8 +564,7 @@  (define-public python-pygsp
                 "")))))))
     (propagated-inputs (list python-numpy python-scikit-image python-scipy))
     (native-inputs
-     (list python-coverage python-coveralls python-flake8
-           python-pytest))
+     (list python-coverage python-coveralls python-pytest))
     (home-page "https://github.com/epfl-lts2/pygsp")
     (synopsis "Graph Signal Processing in Python")
     (description "The PyGSP is a Python package to ease signal processing on
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index db40b99928a..b396a97c0bc 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -217,7 +217,6 @@  (define-public python-uqbar
 and not test_sphinx_book_text_broken_strict")))
     (native-inputs
      (list graphviz
-           python-flake8
            python-isort
            python-mypy
            python-pytest
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index e63dd0f0678..b4f0f65c837 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -175,8 +175,7 @@  (define-public python-funsor
     (propagated-inputs (list python-makefun python-multipledispatch
                              python-numpy python-opt-einsum
                              python-typing-extensions))
-    (native-inputs (list python-flake8
-                         python-isort
+    (native-inputs (list python-isort
                          python-nbsphinx
                          python-pandas
                          python-pillow
@@ -1922,8 +1921,7 @@  (define-public python-imbalanced-learn
                               (getcwd)))))))
     (propagated-inputs (list python-joblib python-numpy python-scikit-learn
                              python-scipy python-threadpoolctl))
-    (native-inputs (list python-flake8
-                         python-keras
+    (native-inputs (list python-keras
                          python-mypy
                          python-pandas
                          python-pytest
@@ -4522,7 +4520,6 @@  (define-public python-captum
      (list python-matplotlib python-numpy python-pytorch python-tqdm))
     (native-inputs (list jupyter
                          python-annoy
-                         python-flake8
                          python-flask
                          python-flask-compress
                          python-ipython
@@ -5009,8 +5006,7 @@  (define-public python-pyro-api
     (build-system python-build-system)
     (arguments '(#:tests? #false)) ;requires pyro
     (native-inputs
-     (list python-flake8
-           python-ipython
+     (list python-ipython
            python-pytest
            python-sphinx
            python-sphinx-rtd-theme))
@@ -5059,7 +5055,6 @@  (define-public python-pyro-ppl
     (native-inputs
      (list ninja
            jupyter
-           python-flake8
            python-graphviz
            python-isort
            python-lap
@@ -5106,8 +5101,7 @@  (define-public python-linear-operator
                              python-pytorch
                              python-scipy
                              python-typeguard))
-    (native-inputs (list python-flake8
-                         python-flake8-print
+    (native-inputs (list python-flake8-print
                          python-pytest
                          python-setuptools
                          python-setuptools-scm
@@ -5138,7 +5132,6 @@  (define-public python-gpytorch
                                        " and not test_t_matmul_matrix"))))
     (propagated-inputs (list python-linear-operator python-scikit-learn))
     (native-inputs (list python-coverage
-                         python-flake8
                          python-flake8-print
                          python-nbval
                          python-pytest
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 6b765dcb3d6..3af2b79b419 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3968,6 +3968,7 @@  (define-public python-mutagen
     (build-system pyproject-build-system)
     (arguments
      (list
+      #:test-flags '(list "--ignore=tests/quality/test_flake8.py")
        #:phases
        #~(modify-phases %standard-phases
            (add-before 'check 'remove-hypothesis-deadlines
@@ -3978,8 +3979,8 @@  (define-public python-mutagen
                  (("( +)@given" all spaces)
                   (string-append spaces "@settings(deadline=None)\n" all))))))))
     (native-inputs
-     (list python-pytest python-hypothesis python-flake8
-           python-setuptools python-wheel))
+     (list python-pytest python-hypothesis python-setuptools python-wheel))
+    (home-page "https://mutagen.readthedocs.io/")
     (synopsis "Read and write audio tags")
     (description "Mutagen is a Python module to handle audio metadata.  It
 supports ASF, FLAC, M4A, Monkey’s Audio, MP3, Musepack, Ogg FLAC, Ogg Speex, Ogg
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index 8ca730df3c3..502ad09a3a6 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -469,7 +469,7 @@  (define-public python-pure-protobuf
         (base32 "15dp5pvazd0jx4wzzh79080ah7hkpd3axh40al9vhzs2hf3v90hx"))))
     (build-system python-build-system)
     (native-inputs
-     (list python-flake8 python-pytest python-pytest-cov python-isort))
+     (list python-pytest python-pytest-cov python-isort))
     (arguments
      `(#:phases
        (modify-phases %standard-phases
@@ -477,8 +477,6 @@  (define-public python-pure-protobuf
            (lambda _
              (invoke "pytest" "--cov-report" "term-missing" "--cov"
                      "pure_protobuf")
-             (invoke "flake8" "pure_protobuf" "tests"
-                     "--ignore=F541")
              (invoke "isort" "-rc" "-c" "pure_protobuf" "tests"))))))
     (home-page "https://pypi.org/project/pure-protobuf/")
     (synopsis "Protobuf implementation using dataclasses")
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index a7794741f42..4cf064e0742 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -978,7 +978,6 @@  (define-public python-ovh
     (arguments (list #:tests? #f))      ; XXX: tests require networking
     (propagated-inputs (list python-requests))
     (native-inputs (list python-coverage
-                         python-flake8
                          python-isort
                          python-pytest
                          python-pytest-cov
@@ -1239,8 +1238,6 @@  (define-public python-furl
     (build-system python-build-system)
     (propagated-inputs
      (list python-six python-orderedmultidict))
-    (native-inputs
-     (list python-flake8))
     (home-page "https://github.com/gruns/furl")
     (synopsis "URL manipulation in Python")
     (description "Furl provides an easy-to-use alternative to the
@@ -1273,7 +1270,6 @@  (define-public python-httplib2
                  (("==") ">=")))))))
     (native-inputs
      (list python-cryptography
-           python-flake8
            python-future
            python-mock
            python-pytest
@@ -7307,7 +7303,7 @@  (define-public python-http-ece
     (propagated-inputs
      (list python-cryptography))
     (native-inputs
-     (list python-coverage python-flake8 python-mock python-nose))
+     (list python-coverage python-mock python-nose))
     (home-page "https://github.com/web-push-libs/encrypted-content-encoding")
     (synopsis "Encrypted Content Encoding for HTTP")
     (description
@@ -8327,8 +8323,7 @@  (define-public python-woob
            python-six
            python-unidecode))
     (native-inputs
-     (list python-coverage python-flake8 python-nose python-selenium
-           python-xunitparser))
+     (list python-coverage python-nose python-selenium python-xunitparser))
     (home-page "https://woob.tech/")
     (synopsis "Woob, Web Outside Of Browsers")
     (description "Woob is a collection of applications able to interact with
@@ -8967,8 +8962,7 @@  (define-public python-starsessions-for-pytorch-lightning
            python-itsdangerous
            python-starlette-for-fastapi-0.88))
     (native-inputs
-     (list python-flake8
-           python-httpx
+     (list python-httpx
            python-mypy
            python-poetry-core
            python-pytest
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e558dcdc83a..fa77102857c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -320,7 +320,6 @@  (define-public python-apprise
     (native-inputs (list python-babel
                          python-coverage
                          python-cryptography
-                         python-flake8
                          python-paho-mqtt
                          python-pytest
                          python-pytest-cov
@@ -1183,8 +1182,7 @@  (define-public python-colorful
         (base32 "0kyy9qhvrb5m9h8xmri7c88i0k1g5qc7017anw39gx44an7mn33y"))))
     (build-system pyproject-build-system)
     (native-inputs
-     (list python-coverage python-flake8 python-pytest python-setuptools
-           python-wheel))
+     (list python-coverage python-pytest python-setuptools python-wheel))
     (propagated-inputs
      (list python-colorama))
     (home-page "http://github.com/timofurrer/colorful")
@@ -2370,7 +2368,7 @@  (define-public python-pymd4c
     (inputs
      (list md4c))
     (native-inputs
-     (list python-flake8 python-pkgconfig pkg-config))
+     (list python-pkgconfig pkg-config))
     (home-page "https://github.com/dominickpastore/pymd4c")
     (synopsis "Python bindings for MD4C")
     (description
@@ -3028,7 +3026,7 @@  (define-public python-pyls-black
     (propagated-inputs
      (list python-black python-lsp-server python-tomli))
     (native-inputs
-     (list python-flake8 python-isort python-mypy python-pytest
+     (list python-isort python-mypy python-pytest
            python-pytest-runner python-setuptools python-wheel))
     (home-page "https://github.com/rupert/pyls-black")
     (synopsis "Black plugin for the Python Language Server")
@@ -7006,7 +7004,6 @@  (define-public python-docx
     (build-system pyproject-build-system)
     (native-inputs
      (list behave
-           python-flake8
            python-mock
            python-pyparsing
            python-pytest
@@ -10799,7 +10796,7 @@  (define-public python-imageio
     (propagated-inputs
      (list python-imageio-ffmpeg python-numpy python-pillow python-tifffile python-setuptools))
     (native-inputs
-     (list python-flake8 python-fsspec python-pytest
+     (list python-fsspec python-pytest
            python-pytest-cov python-wheel))
     (home-page "https://imageio.github.io/")
     (synopsis "Library for reading and writing a wide range of image data")
@@ -11577,8 +11574,7 @@  (define-public python-importlib-resources
              (setenv "PYTHONPATH"
                      (string-append (getcwd) "/_custom_build")))))))
     (native-inputs
-     (list python-flake8
-           python-pytest
+     (list python-pytest
            python-pytest-black
            python-pytest-checkdocs
            python-pytest-cov
@@ -11900,8 +11896,7 @@  (define-public python-jaraco-test
     (arguments
      (list #:test-flags '(list "-k" "http")))
     (propagated-inputs (list python-jaraco-context python-jaraco-functools))
-    (native-inputs (list python-flake8
-                         python-pytest
+    (native-inputs (list python-pytest
                          python-pytest-black
                          python-pytest-checkdocs
                          python-pytest-cov
@@ -13706,8 +13701,7 @@  (define-public python-seaborn
            python-scipy
            python-statsmodels))
     (native-inputs
-     (list python-flake8
-           python-flit-core
+     (list python-flit-core
            python-ipykernel
            python-nbconvert
            python-numpydoc
@@ -18691,8 +18685,7 @@  (define-public python-progressbar2
     (propagated-inputs
      (list python-six python-utils))
     (native-inputs
-     (list python-flake8
-           python-freezegun
+     (list python-freezegun
            python-pycodestyle
            python-pytest
            python-pytest-cache
@@ -20048,8 +20041,7 @@  (define-public python-codespell
     (inputs
       (list python-chardet))
     (native-inputs
-      (list python-flake8
-            python-pygments
+      (list python-pygments
             python-pytest
             python-pytest-cov
             python-pytest-dependency
@@ -21140,8 +21132,7 @@  (define-public python-inflect
              (setenv "PYTHONPATH"
                      (string-append (getcwd) "/_custom_build")))))))
     (propagated-inputs (list python-pydantic))
-    (native-inputs (list python-flake8
-                         python-pygments
+    (native-inputs (list python-pygments
                          python-pytest
                          python-pytest-black
                          python-pytest-checkdocs
@@ -23279,7 +23270,6 @@  (define-public python-argcomplete
                (invoke "python3" "./test/test.py" "-v")))))))
     (native-inputs
      (list python-coverage
-           python-mypy
            python-pexpect
            python-setuptools
            python-setuptools-scm
@@ -24415,8 +24405,7 @@  (define-public python-diff-cover
            python-setuptools ; For pkg_resources.
            python-tomli))
     (native-inputs
-     (list python-flake8
-           python-poetry-core
+     (list python-poetry-core
            python-pylint
            python-pytest
            python-pytest-flake8
@@ -25083,7 +25072,7 @@  (define-public python-validators
     (propagated-inputs
      (list python-decorator python-six))
     (native-inputs
-     (list python-flake8 python-isort python-pytest))
+     (list python-isort python-pytest))
     (home-page "https://github.com/kvesteri/validators")
     (synopsis "Data validation library")
     (description
@@ -25152,8 +25141,7 @@  (define-public python-marshmallow
     (propagated-inputs
      (list python-packaging))
     (native-inputs
-     (list python-flake8
-           python-flake8-bugbear
+     (list python-flake8-bugbear
            python-mypy
            python-pytest
            python-pytz
@@ -25181,7 +25169,6 @@  (define-public python-marshmallow-jsonapi
      (list python-marshmallow))
     (native-inputs
      (list python-faker
-           python-flake8
            python-flake8-bugbear
            python-flask
            python-mock
@@ -25216,8 +25203,7 @@  (define-public python-apispec
     (propagated-inputs
      (list python-packaging))
     (native-inputs
-     (list python-flake8
-           python-flake8-bugbear
+     (list python-flake8-bugbear
            python-marshmallow
            python-mypy
            python-pytest
@@ -25245,7 +25231,6 @@  (define-public python-apispec-webframeworks
     (propagated-inputs (list python-apispec python-setuptools))
     (native-inputs
      (list python-bottle
-           python-flake8
            python-flake8-bugbear
            python-flask
            python-mock
@@ -25294,7 +25279,6 @@  (define-public python-flasgger
      (list python-apispec
            python-apispec-webframeworks
            python-decorator
-           python-flake8
            python-flask-jwt
            python-flask-restful
            python-flex
@@ -26279,7 +26263,7 @@  (define-public python-yq
     (inputs
      (list python-argcomplete python-pyyaml python-xmltodict python-toml jq))
     (native-inputs
-     (list python-coverage python-flake8 python-setuptools-scm python-wheel))
+     (list python-coverage python-setuptools-scm python-wheel))
     (home-page "https://github.com/kislyuk/yq")
     (synopsis "Command-line YAML/XML processor")
     (description
@@ -27286,7 +27270,7 @@  (define-public python-update-checker
         (base32 "04yb5a9mi45ax50m2m0ih6gdvkk1j7gfmy83dd58i1f59axlabba"))))
     (build-system python-build-system)
     (propagated-inputs (list python-requests))
-    (native-inputs (list python-flake8 python-pytest))
+    (native-inputs (list python-pytest))
     (home-page "https://github.com/bboe/update_checker")
     (synopsis "Python module that will check for package updates")
     (description "This package provides a Python module that will check for
@@ -31395,7 +31379,6 @@  (define-public python-eliot
     (native-inputs
      (list python-coverage
            python-dask
-           python-flake8
            python-hypothesis
            python-pytest
            python-setuptools
@@ -32184,7 +32167,7 @@  (define-public python-dateparser
      (list python-dateutil python-pytz python-regex python-ruamel.yaml
            python-tzlocal))
     (native-inputs
-     (list python-flake8 python-pytest python-parameterized tzdata-for-tests
+     (list python-pytest python-parameterized tzdata-for-tests
            python-setuptools python-wheel))
     (arguments
      `(#:phases
@@ -32712,11 +32695,10 @@  (define-public python-versioneer
                 (invoke "pyflakes" "setup.py" "versioneer.py" "git_version.py")
                 (invoke "python" "test/run_pyflakes_src.py")
                 (invoke "pyflakes" "test")
-                (invoke "flake8" "git_version.py" "versioneer.py")
                 (invoke "pycodestyle" "--max-line-length=88"
                         "git_version.py" "versioneer.py")))))))
     (native-inputs
-     (list git-minimal python-flake8 python-pycodestyle python-pyflakes
+     (list git-minimal python-pycodestyle python-pyflakes
            python-pypa-build python-setuptools python-wheel))
     (propagated-inputs
      (list python-tomli))
@@ -33519,7 +33501,7 @@  (define-public python-jinja2-cli
     (propagated-inputs
       (list python-jinja2))
     (native-inputs
-      (list python-flake8 python-jinja2 python-pytest))
+      (list python-jinja2 python-pytest))
     (home-page "https://github.com/mattrobenolt/jinja2-cli")
     (synopsis "Command-line interface to Jinja2")
     (description
@@ -35094,7 +35076,6 @@  (define-public nikola
             python-yapsy))
     (native-inputs
       (list python-coverage
-            python-flake8
             python-freezegun
             python-pytest
             python-pytest-cov))
@@ -35561,7 +35542,7 @@  (define-public python-verspec
                (base32
                 "07n06wv85fm4vl1ird2mja0823js3x322wgs9gdnq1djjyk4ql64"))))
     (build-system python-build-system)
-    (native-inputs (list python-coverage python-flake8 python-mypy
+    (native-inputs (list python-coverage python-mypy
                          python-pretend python-pytest))
     (arguments
      `(#:phases (modify-phases %standard-phases
@@ -35960,7 +35941,7 @@  (define-public python-mike
                 "0yxp816x7s948xsd0fifvq9shg01xdxlifd9rzf5y2rd9iwz3hsn"))))
     (build-system python-build-system)
     (native-inputs
-     (list python-coverage python-flake8 python-shtab))
+     (list python-coverage python-shtab))
     (propagated-inputs
      (list python-jinja2 python-mkdocs python-pyyaml python-verspec))
     (home-page "https://github.com/jimporter/mike")
@@ -35984,7 +35965,6 @@  (define-public python-arpeggio
     (build-system python-build-system)
     (native-inputs (list python-coverage
                          python-coveralls
-                         python-flake8
                          python-mike
                          python-mkdocs
                          python-pytest
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 99c0a121dde..7831802284f 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -1220,7 +1220,6 @@  (define-public python-dolfin-adjoint
      (list pkg-config
            python-coverage
            python-decorator
-           python-flake8
            python-pkgconfig
            python-pytest))
     (propagated-inputs
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index c86ef1e5615..2057649ede5 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -90,7 +90,6 @@  (define-public python-sphinx
            python-colorama
            python-docutils
            python-filelock
-           python-flake8
            python-html5lib
            python-imagesize
            python-importlib-metadata
@@ -189,7 +188,6 @@  (define-public python-sphinx-5
            python-colorama
            python-docutils
            python-filelock
-           python-flake8
            python-html5lib
            python-imagesize
            python-importlib-metadata
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index c2dc1cefef3..0a6f61e2280 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -2447,7 +2447,6 @@  (define-public python-statsmodels
     (native-inputs
      (list python-colorama
            python-cython
-           python-flake8
            python-isort
            python-joblib
            python-matplotlib
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 9d3b93faf90..bf2da58a3ee 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -1675,7 +1675,6 @@  (define-public python-panflute
     (propagated-inputs (list python-click python-pyyaml))
     (native-inputs (list python-configparser
                          python-coverage
-                         python-flake8
                          python-pandocfilters
                          python-pytest
                          python-pytest-cov
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 9da51cb5617..d52d872909d 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -970,7 +970,6 @@  (define-public sshuttle
     (native-inputs
      (list python-setuptools-scm
            ;; For tests only.
-           python-flake8
            python-mock
            python-pytest-cov
            python-pytest-runner))
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index a1c94fe13a9..7da18bc821c 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -654,7 +654,6 @@  (define-public qtile
            python-xcffib))
     (native-inputs
       (list pkg-config
-            python-flake8
             python-pep8-naming
             python-pytest
             python-pytest-cov