diff mbox series

[bug#70858,26/32] build-system/pyproject: Remove python-pytest-isort native-input.

Message ID 20240510075605.6303-26-ngraves@ngraves.fr
State New
Headers show
Series None | expand

Commit Message

Nicolas Graves May 10, 2024, 7:55 a.m. UTC
* gnu/packages/dav.scm (radicale):
  [native-inputs]: Remove python-pytest-isort.

* gnu/packages/python-web.scm (python-tinycss):
  [arguments]<#:test-flags>: Ignore isort tests.
  [native-inputs]: Remove python-pytest-isort.

Change-Id: I706e8c310adbeda49b91c6815d299172ce05df22
---
 gnu/packages/dav.scm        | 1 -
 gnu/packages/python-web.scm | 4 ++--
 2 files changed, 2 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index 0612a72c831..99284220846 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -59,7 +59,6 @@  (define-public radicale
     (native-inputs
      (list python-pytest
            python-pytest-flake8
-           python-pytest-isort
            python-pytest-runner
            python-waitress))
     (propagated-inputs
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8c51282c9cb..340ef0836b4 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5862,9 +5862,9 @@  (define-public python-tinycss
     (build-system pyproject-build-system)
     (arguments
      (list #:test-flags
-           '(list "-k" "not test_speedups")))
+           '(list "-k" "not ISORT and not test_speedups")))
     (native-inputs
-     (list python-pytest-flake8 python-pytest-isort
+     (list python-pytest-flake8
            python-pytest-runner python-setuptools python-wheel))
     (home-page "https://tinycss.readthedocs.io/")
     (synopsis "Complete yet simple CSS parser for Python")