diff mbox series

[bug#70858,28/32] build-system/pyproject: Remove python-pytest-flake8 native-input.

Message ID 20240510075605.6303-28-ngraves@ngraves.fr
State New
Headers show
Series None | expand

Commit Message

Nicolas Graves May 10, 2024, 7:55 a.m. UTC
* gnu/packages/check.scm (python-pytest-enabler, python-pytest-perf):
  [native-inputs]: Remove python-pytest-flake8.

* gnu/packages/dav.scm (radicale)[native-inputs]: Remove
python-pytest-flake8.

* gnu/packages/jupyter.scm (python-nbstripout)[native-inputs]:
Remove python-pytest-flake8.

* gnu/packages/python-check.scm (python-pytest-csv):
  [arguments]<#:test-flags>: Ignore flake8 test.
  [native-inputs]: Remove python-pytest-flake8.

* gnu/packages/python-web.scm (python-mechanicalsoup,
python-tinycss2)[native-inputs]: Remove python-pytest-flake8.
(python-tinycss):
  [arguments]<#:test-flags>: Ignore flake8 tests.
  [native-inputs]: Remove python-pytest-flake8.

* gnu/packages/python-xyz.scm (python-importlib-resources,
python-jaraco-classes, python-jaraco-context, python-jaraco-functools,
python-jaraco-packaging, python-jaraco-test, python-path,
python-pip-run, python-inflect, python-tempora, python-cairosvg)
[native-inputs]: Remove python-pytest-flake8.

Change-Id: I60ad04391d1c4b081e3293d50b3ac93c6430c7bf
---
 gnu/packages/check.scm        |  2 --
 gnu/packages/dav.scm          |  1 -
 gnu/packages/jupyter.scm      |  1 -
 gnu/packages/python-check.scm |  5 +++--
 gnu/packages/python-web.scm   | 10 ++++------
 gnu/packages/python-xyz.scm   | 12 +-----------
 6 files changed, 8 insertions(+), 23 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index f8ead8df4e4..e8f121e9fe9 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2492,7 +2492,6 @@  (define-public python-pytest-enabler
            python-toml))
     (native-inputs (list python-pytest
                          python-pytest-checkdocs
-                         python-pytest-flake8
                          python-pytest-mypy
                          python-setuptools
                          python-setuptools-scm
@@ -2665,7 +2664,6 @@  (define-public python-pytest-perf
      (list python-pytest
            python-pytest-checkdocs
            python-pytest-enabler
-           python-pytest-flake8
            python-pytest-mypy
            python-setuptools
            python-wheel))
diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index 99284220846..b5a1ba749d8 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -58,7 +58,6 @@  (define-public radicale
     (build-system python-build-system)
     (native-inputs
      (list python-pytest
-           python-pytest-flake8
            python-pytest-runner
            python-waitress))
     (propagated-inputs
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index c25663e4da6..4bc0bc2a8f4 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -817,7 +817,6 @@  (define-public python-nbstripout
     (native-inputs
      (list python-pytest
            python-pytest-cram
-           python-pytest-flake8
            python-pytest-runner
            python-setuptools
            python-wheel))
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index fdef98f6c8a..4b5ca23569a 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -214,9 +214,10 @@  (define-public python-pytest-csv
         (base32
          "17518f2fn5l98lyk9p8r7215c1whi61imzrh6ahrmcksr8w0zz04"))))
     (build-system pyproject-build-system)
+    (arguments
+     (list #:test-flags '(list "--ignore=tests/test_flake8.py")))
     (native-inputs
-     (list python-pytest-flake8
-           python-pytest-xdist
+     (list python-pytest-xdist
            python-setuptools
            python-tabulate
            python-wheel))
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 5f19d93ea19..2a7d083b9de 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1578,8 +1578,7 @@  (define-public python-mechanicalsoup
     (propagated-inputs
      (list python-beautifulsoup4 python-lxml python-requests python-six))
     (native-inputs
-     (list python-pytest-flake8
-           python-pytest-httpbin
+     (list python-pytest-httpbin
            python-pytest-mock
            python-pytest-runner
            python-requests-mock
@@ -5861,10 +5860,9 @@  (define-public python-tinycss
     (build-system pyproject-build-system)
     (arguments
      (list #:test-flags
-           '(list "-k" "not ISORT and not test_speedups")))
+           '(list "-k" "not ISORT and not FLAKE8 and not test_speedups")))
     (native-inputs
-     (list python-pytest-flake8
-           python-pytest-runner python-setuptools python-wheel))
+     (list python-pytest-runner python-setuptools python-wheel))
     (home-page "https://tinycss.readthedocs.io/")
     (synopsis "Complete yet simple CSS parser for Python")
     (description
@@ -5905,7 +5903,7 @@  (define-public python-tinycss2
     (propagated-inputs
      (list python-webencodings))
     (native-inputs
-     (list python-flit python-pytest python-pytest-flake8 python-pytest-isort))
+     (list python-flit python-pytest python-pytest-isort))
     (home-page "https://tinycss2.readthedocs.io/")
     (synopsis "Low-level CSS parser for Python")
     (description "@code{tinycss2} can parse strings, return Python objects
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9c15ca8e566..1b3837dddc4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11525,7 +11525,6 @@  (define-public python-importlib-resources
      (list python-pytest
            python-pytest-checkdocs
            python-pytest-enabler
-           python-pytest-flake8
            python-pytest-mypy
            python-setuptools-57
            python-setuptools-scm))
@@ -11653,7 +11652,6 @@  (define-public python-jaraco-classes
     (native-inputs
      (list python-pytest
            python-pytest-checkdocs
-           python-pytest-flake8
            python-pytest-mypy
            python-setuptools
            python-setuptools-scm
@@ -11744,7 +11742,6 @@  (define-public python-jaraco-context
     (native-inputs
      (list python-pytest
            python-pytest-checkdocs
-           python-pytest-flake8
            python-pytest-mypy
            python-setuptools
            python-setuptools-scm
@@ -11777,7 +11774,6 @@  (define-public python-jaraco-functools
      (list python-jaraco-classes
            python-pytest
            python-pytest-checkdocs
-           python-pytest-flake8
            python-pytest-mypy
            python-setuptools
            python-setuptools-scm
@@ -11807,7 +11803,6 @@  (define-public python-jaraco-packaging
     (propagated-inputs
      (list python-pytest
            python-pytest-checkdocs
-           python-pytest-flake8
            python-rst.linker
            python-setuptools
            python-setuptools-scm
@@ -11837,7 +11832,6 @@  (define-public python-jaraco-test
     (native-inputs (list python-pytest
                          python-pytest-checkdocs
                          python-pytest-enabler
-                         python-pytest-flake8
                          python-pytest-mypy
                          python-setuptools
                          python-wheel))
@@ -16510,7 +16504,6 @@  (define-public python-path
                python-pytest
                python-pytest-checkdocs
                python-pytest-enabler
-               python-pytest-flake8
                python-pytest-mypy)))
     (properties (alist-delete 'hidden?
                               (package-properties
@@ -16614,7 +16607,6 @@  (define-public python-pip-run
                python-pytest
                python-pytest-checkdocs
                python-pytest-enabler
-               python-pytest-flake8
                python-pytest-mypy)))
     (properties (alist-delete 'hidden? (package-properties
                                         python-pip-run-bootstrap)))))
@@ -21051,7 +21043,6 @@  (define-public python-inflect
                          python-pytest
                          python-pytest-checkdocs
                          python-pytest-enabler
-                         python-pytest-flake8
                          python-pytest-mypy
                          ;; For the version number
                          python-setuptools-scm
@@ -25899,7 +25890,6 @@  (define-public python-tempora
            python-pytest
            python-pytest-checkdocs
            python-pytest-enabler
-           python-pytest-flake8
            python-pytest-freezegun
            python-pytest-mypy
            python-setuptools-scm
@@ -29569,7 +29559,7 @@  (define-public python-cairosvg
      (list python-cairocffi python-cssselect2 python-defusedxml
            python-pillow python-tinycss2))
     (native-inputs
-     (list python-pytest-flake8 python-pytest-isort python-pytest-runner
+     (list python-pytest-isort python-pytest-runner
            python-setuptools python-wheel))
     (home-page "https://cairosvg.org/")
     (synopsis "SVG to PDF/PS/PNG converter based on Cairo")