diff mbox series

[bug#70858,10/32] gnu: python-openid: Remove python-coverage native-input.

Message ID 20240510075605.6303-10-ngraves@ngraves.fr
State New
Headers show
Series None | expand

Commit Message

Nicolas Graves May 10, 2024, 7:55 a.m. UTC
* gnu/packages/python-web.scm (python-openid):
  [native-inputs]: Remove python-coverage.
  [arguments]<#:phases>: Rewrite check phase.

Change-Id: Id4ea5abc531f5fd84b60ff22407eb608f1e6ac29
---
 gnu/packages/python-web.scm | 17 +++++++++--------
 1 file changed, 9 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 942999f6cf9..fe79f629bb8 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2341,17 +2341,18 @@  (define-public python-openid
          "1bxf9a3ny1js422j962zfzl4a9dhj192pvai05whn7j0iy9gdyrk"))))
     (build-system python-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-        (replace 'check
-          (lambda* (#:key tests? #:allow-other-keys)
-            (when tests?
-              (invoke "coverage" "run" "-m"
-                      "unittest" "openid.test.test_suite")))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (if tests?
+                  (invoke "python" "-m" "unittest" "openid.test.test_suite")
+                  (format #t "test suite not run~%")))))))
     (propagated-inputs
      (list python-defusedxml))
     (native-inputs
-     (list python-coverage python-psycopg2 python-django))
+     (list python-psycopg2 python-django))
     (home-page "https://github.com/necaris/python3-openid")
     (synopsis "OpenID support for servers and consumers")
     (description "This library provides OpenID authentication for Python, both