diff mbox series

[bug#70858,24/32] gnu: python-django-contact-form: Remove python-pytest-cov native-input.

Message ID 20240510075605.6303-24-ngraves@ngraves.fr
State New
Headers show
Series None | expand

Commit Message

Nicolas Graves May 10, 2024, 7:55 a.m. UTC
* gnu/packages/django.scm (python-django-contact-form):
  [native-inputs]: Remove python-pytest-cov.
  [build-system]: Upgrade to pyproject-build-system.
  [arguments]<#:phases>: Remove coverage tests for check phase.

Change-Id: I4d0fc406401b7e923f7efa084dbe8ea3753e50fc
---
 gnu/packages/django.scm | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 3ab2bc139d1..726dd77639e 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -838,16 +838,13 @@  (define-public python-django-contact-form
               (sha256
                (base32
                 "1my9hkrylckp5vfqg9b0kncrdlxjnwxll56sdciqn4v19i4wbq1y"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
            (lambda _
-             (invoke "coverage" "run" "--source" "contact_form"
-                     "runtests.py"))))))
-    (native-inputs
-     (list python-coverage))
+             (invoke "python" "runtests.py"))))))
     (propagated-inputs
      (list python-django))
     (home-page "https://github.com/ubernostrum/django-contact-form")