diff mbox series

[bug#70858,27/32] build-system/pyproject: Remove python-pytest-black native-input.

Message ID 20240510075605.6303-27-ngraves@ngraves.fr
State New
Headers show
Series None | expand

Commit Message

Nicolas Graves May 10, 2024, 7:55 a.m. UTC
* gnu/packages/check.scm (python-pytest-perf, python-pytest-enabler)
[native-inputs]: Remove python-pytest-black.

* gnu/packages/python-web.scm (python-portend)[native-inputs]:
Remove python-pytest-black.

* gnu/packages/python-xyz.scm (python-importlib-resources,
python-jaraco-classes, python-jaraco-collections,
python-jaraco-context, python-jaraco-functools, python-jaraco-test,
python-jaraco-text, python-legacy-api-wrap, python-path,
python-pip-run, python-inflect, python-isort, python-tempora,
python-sparse)[native-inputs]: Remove python-pytest-black.

Change-Id: Ib46f1c4a3cc33821cda3d7b2172d36158aa812c9
---
 gnu/packages/check.scm      |  2 --
 gnu/packages/python-web.scm |  1 -
 gnu/packages/python-xyz.scm | 22 +++++-----------------
 3 files changed, 5 insertions(+), 20 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 6b16ec7711b..f8ead8df4e4 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2491,7 +2491,6 @@  (define-public python-pytest-enabler
            python-jaraco-functools
            python-toml))
     (native-inputs (list python-pytest
-                         python-pytest-black
                          python-pytest-checkdocs
                          python-pytest-flake8
                          python-pytest-mypy
@@ -2664,7 +2663,6 @@  (define-public python-pytest-perf
                            "and not upstream_url"))))
     (native-inputs
      (list python-pytest
-           python-pytest-black
            python-pytest-checkdocs
            python-pytest-enabler
            python-pytest-flake8
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 340ef0836b4..5f19d93ea19 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -311,7 +311,6 @@  (define-public python-portend
     (propagated-inputs (list python-tempora))
     ;; TODO: Add python-pytest-ruff to native-inputs once it has been packaged.
     (native-inputs (list python-pytest
-                         python-pytest-black
                          python-pytest-checkdocs
                          python-pytest-enabler
                          python-pytest-mypy
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bc4761e4c38..9c15ca8e566 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8686,7 +8686,7 @@  (define-public python-sparse
      (list python-numba python-numpy python-scipy))
     (native-inputs
      (list python-dask python-importlib-metadata python-pytest
-           python-pytest-black python-setuptools))
+           python-setuptools))
     (home-page "https://github.com/pydata/sparse/")
     (synopsis "Library for multi-dimensional sparse arrays")
     (description
@@ -11523,7 +11523,6 @@  (define-public python-importlib-resources
                      (string-append (getcwd) "/_custom_build")))))))
     (native-inputs
      (list python-pytest
-           python-pytest-black
            python-pytest-checkdocs
            python-pytest-enabler
            python-pytest-flake8
@@ -11653,7 +11652,6 @@  (define-public python-jaraco-classes
       #:test-flags '(list "-k" "not project")))
     (native-inputs
      (list python-pytest
-           python-pytest-black
            python-pytest-checkdocs
            python-pytest-flake8
            python-pytest-mypy
@@ -11686,7 +11684,6 @@  (define-public python-jaraco-collections
     ;; TODO: Add python-pytest-ruff to native-inputs once it has been
     ;; packaged.
     (native-inputs (list python-pytest
-                         python-pytest-black
                          python-pytest-checkdocs
                          python-pytest-enabler
                          python-pytest-mypy
@@ -11746,7 +11743,6 @@  (define-public python-jaraco-context
            #:test-flags '(list "-k" "not project")))
     (native-inputs
      (list python-pytest
-           python-pytest-black
            python-pytest-checkdocs
            python-pytest-flake8
            python-pytest-mypy
@@ -11780,7 +11776,6 @@  (define-public python-jaraco-functools
     (native-inputs
      (list python-jaraco-classes
            python-pytest
-           python-pytest-black
            python-pytest-checkdocs
            python-pytest-flake8
            python-pytest-mypy
@@ -11840,7 +11835,6 @@  (define-public python-jaraco-test
      (list #:test-flags '(list "-k" "http")))
     (propagated-inputs (list python-jaraco-context python-jaraco-functools))
     (native-inputs (list python-pytest
-                         python-pytest-black
                          python-pytest-checkdocs
                          python-pytest-enabler
                          python-pytest-flake8
@@ -11873,7 +11867,6 @@  (define-public python-jaraco-text
     ;; TODO: Add python-pytest-ruff to native-inputs once it has been
     ;; packaged.
     (native-inputs (list python-pytest
-                         python-pytest-black
                          python-pytest-checkdocs
                          python-pytest-enabler
                          python-pytest-mypy
@@ -16255,8 +16248,7 @@  (define-public python-legacy-api-wrap
          "06qhp0g543dy98vpa41hwdalvdbsjfc3ldk474yr9sd75mhl8jh3"))))
     (build-system python-build-system)
     (propagated-inputs
-     (list python-get-version python-pytest python-pytest-black
-           python-setuptools))
+     (list python-get-version python-pytest python-setuptools))
     (home-page "https://github.com/flying-sheep/legacy-api-wrap")
     (synopsis "Legacy API wrapper")
     (description "This module defines a decorator to wrap legacy APIs.  The
@@ -16516,7 +16508,6 @@  (define-public python-path
                python-packaging
                python-pygments
                python-pytest
-               python-pytest-black
                python-pytest-checkdocs
                python-pytest-enabler
                python-pytest-flake8
@@ -16621,7 +16612,6 @@  (define-public python-pip-run
        (append python-nbformat
                python-pygments
                python-pytest
-               python-pytest-black
                python-pytest-checkdocs
                python-pytest-enabler
                python-pytest-flake8
@@ -21059,7 +21049,6 @@  (define-public python-inflect
     (propagated-inputs (list python-pydantic))
     (native-inputs (list python-pygments
                          python-pytest
-                         python-pytest-black
                          python-pytest-checkdocs
                          python-pytest-enabler
                          python-pytest-flake8
@@ -24089,7 +24078,8 @@  (define-public python-isort
     (arguments
      (list
       #:test-flags '(list "tests/unit/" "-k" "not test_gitignore"
-                          "--ignore=tests/unit/test_deprecated_finders.py")
+                          "--ignore=tests/unit/test_deprecated_finders.py"
+                          "--ignore=tests/unit/profiles/test_black.py")
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'install 'install-example-plugins
@@ -24107,8 +24097,7 @@  (define-public python-isort
                 (apply invoke "pip" "--no-cache-dir" "--no-input"
                        "install"  "--user" "--no-deps" example-whls)))))))
     (native-inputs
-     (list python-black
-           python-colorama
+     (list python-colorama
            python-hypothesmith
            python-libcst-minimal
            python-natsort
@@ -25908,7 +25897,6 @@  (define-public python-tempora
     (native-inputs
      (list python-freezegun
            python-pytest
-           python-pytest-black
            python-pytest-checkdocs
            python-pytest-enabler
            python-pytest-flake8