diff mbox series

[bug#70858,14/32] gnu: python-versioneer: Remove python-pyflakes native-input.

Message ID 20240510075605.6303-14-ngraves@ngraves.fr
State New
Headers show
Series None | expand

Commit Message

Nicolas Graves May 10, 2024, 7:55 a.m. UTC
* gnu/packages/python-xyz.scm (python-versioneer):
  [arguments]<#:phases>: Remove pyflakes tests.
  [native-inputs]: Remove python-pyflakes.

Change-Id: If2b8ab397f2ad25f73c434d28d8382f13d417f94
---
 gnu/packages/python-xyz.scm | 8 ++------
 1 file changed, 2 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8e54608678d..c4167de452d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -32655,13 +32655,9 @@  (define-public python-versioneer
                 (invoke "python" "test/git/test_git.py" "-v")
                 ;; Some invocation tests require the network.
                 ;;(invoke "python" "test/git/test_invocations.py" "-v")
-                (invoke "python" "setup.py" "make_long_version_py_git")
-                (invoke "pyflakes" "setup.py" "versioneer.py" "git_version.py")
-                (invoke "python" "test/run_pyflakes_src.py")
-                (invoke "pyflakes" "test")))))))
+                (invoke "python" "setup.py" "make_long_version_py_git")))))))
     (native-inputs
-     (list git-minimal python-pyflakes
-           python-pypa-build python-setuptools python-wheel))
+     (list git-minimal python-pypa-build python-setuptools python-wheel))
     (propagated-inputs
      (list python-tomli))
     (home-page "https://github.com/python-versioneer/python-versioneer")