diff mbox series

[bug#70858,32/32] gnu: abjad-ext-ipython: Remove uneeded inputs.

Message ID 20240510075605.6303-32-ngraves@ngraves.fr
State New
Headers show
Series None | expand

Commit Message

Nicolas Graves May 10, 2024, 7:55 a.m. UTC
* gnu/packages/music.scm (abjad-ext-ipython):
  [arguments]<#:phases>: Remove unwanted dev dependencies in phase
  losen-requirements.
  [native-inputs]: Remove python-black, python-flake8, python-isort,
  python-mypy, python-pytest-cov, python-iniconfig,
  python-pytest-helpers-namespace.
  [propagated-inputs]: Remove python-sphinx-autodoc-typehints.

Change-Id: Id337da7731bc04d69831096b31f52e0e4c6a13c0
---
 gnu/packages/music.scm | 16 +++++-----------
 1 file changed, 5 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 5420a140657..45daa9438ae 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1790,7 +1790,9 @@  (define-public abjad-ext-ipython
              (substitute* "setup.py"
                ;; Don't require a specific version of abjad.
                (("abjad==")
-                "abjad>="))))
+                "abjad>=")
+               ;; XXX: Remove unwanted dev dependencies.
+               (("\"(black|flake8|isort|mypy|pytest)[^,]*,") ""))))
          (replace 'check
            (lambda* (#:key tests? inputs outputs #:allow-other-keys)
              (when tests?
@@ -1800,17 +1802,9 @@  (define-public abjad-ext-ipython
                (invoke "jupyter" "nbconvert" "--to=html"
                "--ExecutePreprocessor.enabled=True" "tests/test.ipynb")))))))
     (native-inputs
-     (list lilypond
-           python-black
-           python-flake8
-           python-iniconfig
-           python-isort
-           python-mypy
-           python-pytest
-           python-pytest-cov
-           python-pytest-helpers-namespace))
+     (list lilypond python-pytest))
     (propagated-inputs
-     (list abjad jupyter python-sphinx-autodoc-typehints))
+     (list abjad jupyter))
     (home-page "https://abjad.github.io")
     (synopsis "Abjad IPython Extension")
     (description