diff mbox series

[bug#39416,24/34] gnu: Add package r-rockchalk

Message ID 20200204135626.28261-24-ldb@leibniz-psychology.org
State Accepted
Headers show
Series [bug#39416,01/34] gnu: Add package r-fracdiff | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Lars-Dominik Braun Feb. 4, 2020, 1:56 p.m. UTC
* gnu/packages/cran.scm (r-rockchalk): New variable.
---
 gnu/packages/cran.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ebfa5d9529..2df2f90d37 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19916,3 +19916,37 @@  recoding.  We are eager to have community feedback about the variable key and
 the vignette about it.  In version 1.67, the function semTable() is deprecated.
 We have proposed a new package of that name.")
     (license license:gpl2)))
+
+(define-public r-rockchalk
+  (package
+    (name "r-rockchalk")
+    (version "1.8.144")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "rockchalk" version))
+        (sha256
+          (base32
+            "07dp1n155b9gfvk8l30h6bhjbhbylsjxfzns08mryn4mxj3nqpnb"))))
+    (properties `((upstream-name . "rockchalk")))
+    (build-system r-build-system)
+    (propagated-inputs
+      `(("r-cardata" ,r-cardata)
+        ("r-kutils" ,r-kutils)
+        ("r-lme4" ,r-lme4)
+        ("r-mass" ,r-mass)))
+    (home-page
+      "https://cran.r-project.org/package=rockchalk")
+    (synopsis
+      "Regression Estimation and Presentation")
+    (description
+      "This package provides a collection of functions for interpretation and
+presentation of regression analysis.  These functions are used to produce the
+statistics lectures in <http://pj.freefaculty.org/guides>.  Includes regression
+diagnostics, regression tables, and plots of interactions and \"moderator\"
+variables.  The emphasis is on \"mean-centered\" and \"residual-centered\"
+predictors.  The vignette @code{rockchalk} offers a fairly comprehensive
+overview.  The vignette @code{Rstyle} has advice about coding in R.  The
+package title @code{rockchalk} refers to our school motto, \"Rock Chalk
+Jayhawk, Go K.U.\".")
+    (license license:gpl3+)))