diff mbox series

[bug#39416,16/34] gnu: Add package r-matrixcalc

Message ID 20200204135626.28261-16-ldb@leibniz-psychology.org
State Accepted
Headers show
Series [bug#39416,01/34] gnu: Add package r-fracdiff | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Lars-Dominik Braun Feb. 4, 2020, 1:56 p.m. UTC
* gnu/packages/cran.scm (r-matrixcalc): New variable.
---
 gnu/packages/cran.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b26b63afcb..81e8731383 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19682,3 +19682,24 @@  Response, and the Generalized Partial Credit Models.")
     (description
       "The mi package provides functions for data manipulation, imputing missing values in an approximate Bayesian framework, diagnostics of the models used to generate the imputations, confidence-building mechanisms to validate some of the assumptions of the imputation algorithm, and functions to analyze multiply imputed data sets with the appropriate degree of sampling uncertainty.")
     (license license:gpl2+)))
+
+(define-public r-matrixcalc
+  (package
+    (name "r-matrixcalc")
+    (version "1.0-3")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "matrixcalc" version))
+        (sha256
+          (base32
+            "1c4w9dhi5w98qj1wwh9bbpnfk39rhiwjbanalr8bi5nmxkpcmrhp"))))
+    (properties `((upstream-name . "matrixcalc")))
+    (build-system r-build-system)
+    (home-page
+      "https://cran.r-project.org/web/packages/matrixcalc")
+    (synopsis
+      "Collection of functions for matrix calculations")
+    (description
+      "This package provides a collection of functions to support matrix calculations for probability, econometric and numerical analysis.  There are additional functions that are comparable to APL functions which are useful for actuarial models such as pension mathematics.  This package is used for teaching and research purposes at the Department of Finance and Risk Engineering, New York University, Polytechnic Institute, Brooklyn, NY 11201.")
+    (license license:gpl2+)))