diff mbox series

[bug#39416,19/34] gnu: Add package r-regsem

Message ID 20200204135626.28261-19-ldb@leibniz-psychology.org
State Accepted
Headers show
Series [bug#39416,01/34] gnu: Add package r-fracdiff | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Lars-Dominik Braun Feb. 4, 2020, 1:56 p.m. UTC
* gnu/packages/cran.scm (r-regsem): New variable.
---
 gnu/packages/cran.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 100d9bd4dd..cf230ec076 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19752,3 +19752,33 @@  least squares.")
     (description
       "This package provides useful tools for structural equation modeling.")
     (license license:gpl2+)))
+
+(define-public r-regsem
+  (package
+    (name "r-regsem")
+    (version "1.3.9")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "regsem" version))
+        (sha256
+          (base32
+            "1klml4bp76mplipxaca7fk653cjxgdmmiciksxgiglxkzmf2bdps"))))
+    (properties `((upstream-name . "regsem")))
+    (build-system r-build-system)
+    (propagated-inputs
+      `(("r-lavaan" ,r-lavaan)
+        ("r-rcpp" ,r-rcpp)
+        ("r-rcpparmadillo" ,r-rcpparmadillo)
+        ("r-rsolnp" ,r-rsolnp)))
+    (home-page
+      "https://cran.r-project.org/package=regsem")
+    (synopsis
+      "Regularized Structural Equation Modeling")
+    (description
+      "Uses both ridge and lasso penalties (and extensions) to penalize
+specific parameters in structural equation models.  The package offers
+additional cost functions, cross validation, and other extensions beyond
+traditional structural equation models.  Also contains a function to perform
+exploratory mediation (XMed).")
+    (license license:gpl2+)))