diff mbox series

[bug#39416,22/34] gnu: Add package r-openmx

Message ID 20200204135626.28261-22-ldb@leibniz-psychology.org
State Accepted
Headers show
Series [bug#39416,01/34] gnu: Add package r-fracdiff | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Lars-Dominik Braun Feb. 4, 2020, 1:56 p.m. UTC
* gnu/packages/cran.scm (r-openmx): New variable.
---
 gnu/packages/cran.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a607abd262..0223b97a62 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19843,3 +19843,41 @@  core support code suitable for more specialized IRT packages to build upon.
 Complete access to optimized C functions are made available with
 @code{R_RegisterCCallable()}.")
     (license license:gpl3+)))
+
+(define-public r-openmx
+  (package
+    (name "r-openmx")
+    (version "2.15.5")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "OpenMx" version))
+        (sha256
+          (base32
+            "1wbzhmyb1lnk39dkcyccmblxvniwsghh0jd94x05pk6yrcq8im5v"))))
+    (properties `((upstream-name . "OpenMx")))
+    (build-system r-build-system)
+    (propagated-inputs
+      `(("r-bh" ,r-bh)
+        ("r-digest" ,r-digest)
+        ("r-mass" ,r-mass)
+        ("r-matrix" ,r-matrix)
+        ("r-rcpp" ,r-rcpp)
+        ("r-rcppeigen" ,r-rcppeigen)
+        ("r-rpf" ,r-rpf)
+        ("r-stanheaders" ,r-stanheaders)))
+    (native-inputs `(("gfortran" ,gfortran)))
+    (home-page "http://openmx.ssri.psu.edu")
+    (synopsis
+      "Extended Structural Equation Modelling")
+    (description
+      "Create structural equation models that can be manipulated
+programmatically.  Models may be specified with matrices or paths (LISREL or
+RAM) Example models include confirmatory factor, multiple group, mixture
+distribution, categorical threshold, modern test theory, differential Fit
+functions include full information maximum likelihood, maximum likelihood, and
+weighted least squares.  equations, state space, and many others.  Support and
+advanced package binaries available at <http://openmx.ssri.psu.edu>.  The
+software is described in Neale, Hunter, Pritikin, Zahery, Brick, Kirkpatrick,
+Estabrook, Bates, Maes, & Boker (2016) <doi:10.1007/s11336-014-9435-8>.")
+    (license license:asl2.0)))