diff mbox series

[bug#39416,11/34] gnu: Add package r-stm

Message ID 20200204135626.28261-11-ldb@leibniz-psychology.org
State Accepted
Headers show
Series [bug#39416,01/34] gnu: Add package r-fracdiff | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Lars-Dominik Braun Feb. 4, 2020, 1:56 p.m. UTC
* gnu/packages/cran.scm (r-stm): New variable.
---
 gnu/packages/cran.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9e5006b5f3..4b7ce21b1f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19543,3 +19543,40 @@  and co-authors and the C++ code for fitting LDA models using Gibbs sampling by
 Xuan-Hieu Phan and co-authors.")
     (license license:gpl2)))
 
+(define-public r-stm
+  (package
+    (name "r-stm")
+    (version "1.3.5")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "stm" version))
+        (sha256
+          (base32
+            "1yyfxaxqc6yq0yq68zhdnhpwpvsyp71dlmivn7zxixfmp932s6cn"))))
+    (properties `((upstream-name . "stm")))
+    (build-system r-build-system)
+    (propagated-inputs
+      `(("r-data-table" ,r-data-table)
+        ("r-glmnet" ,r-glmnet)
+        ("r-lda" ,r-lda)
+        ("r-matrix" ,r-matrix)
+        ("r-matrixstats" ,r-matrixstats)
+        ("r-quadprog" ,r-quadprog)
+        ("r-quanteda" ,r-quanteda)
+        ("r-rcpp" ,r-rcpp)
+        ("r-rcpparmadillo" ,r-rcpparmadillo)
+        ("r-slam" ,r-slam)
+        ("r-stringr" ,r-stringr)))
+    (home-page "http://www.structuraltopicmodel.com/")
+    (synopsis
+      "Estimation of the Structural Topic Model")
+    (description
+      "The Structural Topic Model (STM) allows researchers to estimate topic
+models with document-level covariates.  The package also includes tools for
+model selection, visualization, and estimation of topic-covariate regressions.
+Methods developed in Roberts et al (2014) <doi:10.1111/ajps.12103> and Roberts
+et al (2016) <doi:10.1080/01621459.2016.1141684>.  Vignette is Roberts et al
+(2019) <doi:10.18637/jss.v091.i02>.")
+    (license license:expat)))
+