diff mbox series

[bug#39416,12/34] gnu: Add package r-polycor

Message ID 20200204135626.28261-12-ldb@leibniz-psychology.org
State Accepted
Headers show
Series [bug#39416,01/34] gnu: Add package r-fracdiff | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Lars-Dominik Braun Feb. 4, 2020, 1:56 p.m. UTC
* gnu/packages/cran.scm (r-polycor): New variable.
---
 gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4b7ce21b1f..8c436d4c75 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19580,3 +19580,27 @@  et al (2016) <doi:10.1080/01621459.2016.1141684>.  Vignette is Roberts et al
 (2019) <doi:10.18637/jss.v091.i02>.")
     (license license:expat)))
 
+(define-public r-polycor
+  (package
+    (name "r-polycor")
+    (version "0.7-10")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "polycor" version))
+        (sha256
+          (base32
+            "0wzwzklflbhi8sv9m7ijwr16v9zmkk0j0v4pbcpf32f8lbn3psna"))))
+    (properties `((upstream-name . "polycor")))
+    (build-system r-build-system)
+    (propagated-inputs
+      `(("r-matrix" ,r-matrix) ("r-mvtnorm" ,r-mvtnorm)))
+    (home-page
+      "https://r-forge.r-project.org/projects/polycor/")
+    (synopsis
+      "Polychoric and Polyserial Correlations")
+    (description
+      "Computes polychoric and polyserial correlations by quick \"two-step\"
+methods or ML, optionally with standard errors; tetrachoric and biserial
+correlations are special cases.")
+    (license license:gpl2+)))